Page 1 of 1

Bug found in Owl's Roost Tavern (Aridell)

Posted: February 1st, 2009, 1:19 pm
by sjaffe
Ok, I'm not sure if you're still taking bug reports for Book I or not but, if you can figure out why this happens, maybe you can prevent it in Book II.

Anyway, there is only one place in the whole game where it is always safe to rest and spend the night - the Owl's Roost Tavern in Aridell run by Porter. In a game I was recently playing, about midway through the game (I was at the point where I was trying to get into Crakmir through the Ossuary), I went in to the tavern for the night. I went into the bedroom where you wake up in order to talk to Porter, who had wandered into there. I paid my money and woke up in the morning. Porter was still in the room. I walked over to the cabinet where I was storing stuff to swap inventory around. Porter attacked me!

I reloaded the game from the night before, and tried it again. I happened again. I then left without swapping around inventory and went on adventuring. A few games days later, I came back to the inn. This time Porter wasn't in the room. I sold him some items, then bought the room for the night. When I woke up in the morning, Porter was still in the outer room. I went into the cabinet to swap inventory again. When I came out of the bedroom, Porter attacked! At that point, I was forced to kill him so I spent the rest of the game without a safe place to sleep and recover hit points/mana.

I don't know why Porter suddenly went hostile while I was rummaging around in my own stuff. The other townsfolk were not hostile. And, it only happened this game and not in any of the others I've played. I wasn't wearing the Evil Amulet, or any item marked as "Evil". I did not attack Porter first. I also didn't see a message in the text area about Porter hearing a crime being committed as if I had robbed a chest. I can't think of what I did that might have caused Porter to become hostile except open the chest that I've opened dozens of times previously in the game, and moved my own possessions around between the drawers and my pack.

Just thought you might want to know. It's really not fun to lose your only truly safe haven. Hopefully, this won't happen in Book II.

BTW, I'm playing on a Mac, OS 10.4.11. i don't know the version number of Eschalon (there doesn't seem to be an easy way to find out, even Info in the Finder doesn't say) but the date on it is Dec. 2007.

Hope this helps...

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: February 1st, 2009, 1:26 pm
by Randomizer
Did you leave the door open so Porter can see into the room when you removed items from the cabinet? Otherwise it should have been safe.

That has to be the most depressing problem of finding storage places that are easily accessible and that don't trigger hostilities when you retrieve them.

I've found that you can camp in most places and not trigger the appearance of thugs. You can set up in the street of Aridell as long as there is enough room to pitch a tent.

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: February 2nd, 2009, 8:17 am
by sjaffe
The door has ALWAYS been open, in all games, in all resting times. This particular incident was no different from any other.

As for resting in the streets of Aridell, every time I've tried it, the game won't let me and tells me it's not safe to rest there. I've tried it everywhere within Aridell where it looks like there's enough room for the tent...

Meantime, I've found an "alternate" location. The area in the mountains near Blackwater where the teleport pad is - there's enough space to pitch the tent if you stand on the square immediately south of the pad. I think it might be an intended safe spot because the game designers probably thought that a player escaping from the goblin citadel in need of healing would be annoyed to teleport into that area into the middle of wandering creatures so probably designed that spot as a safe spot. At least, i would have designed it that way. :-) Anyway, it seems to work.

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: March 9th, 2009, 2:30 pm
by moramber
It's not a bug. Anyone will attack you when he sees you taking something out of a chest or cupboard in his/her house even if you put it there yourself.

I was quite dissapointed when madock started hitting me. I thought I could leave things save with him again.

Porter was probably not in the right spot to be able to watch you plundering the cabinet, through the open door.

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: March 10th, 2009, 12:34 am
by CrazyBernie
Definitely sounds like you were in his line of sight, if you left the door open. Also, I never had any problems staying @ The Lonely Spirits Tavern in Blackwater as a regular guest.

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: June 20th, 2009, 9:54 pm
by Atch
hehe, I remember when I *used* to have to rest.

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: July 8th, 2009, 8:47 am
by Painted Lady
I have had something similar happen. I was in Shadowmirk talking to Erubor about saving Thaermore. He told me to feel free to take anything in the chest in his bedroom that might help the cause. I went in and opened the chest. Got a message that he had seen a crime being committed and he attacked me.

Now whenever I'm ready for that step I do a quick save and make sure he isn't in my line of sight before I quickly grab the items. Don't know why I always take the widget, but way deep down I keep wondering if I might find a use for it.......

Also, regarding storing items for later use, I use the storage barrels that are scattered around the towns. Nobody cares if you poke around in them. Also, even the ones you have blasted apart work just fine.

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: July 8th, 2009, 2:32 pm
by Dragonlady
If possible in any game I play, I always shut the door! Hearing a crime being commited doesn't stir up trouble but being seen will. I'm playing book 1 again and am having trouble in the first town trying to get into the 2 locked rooms. The guard is out of sight but that dang priest wandered out of the temple and keeps spotting me! :mrgreen: (and yes, I took the torch before trying)

Re: Bug found in Owl's Roost Tavern (Aridell)

Posted: July 8th, 2009, 10:14 pm
by Randomizer
What's funny is that they don't care if you stand there and hack the door to pieces. No experience but it's legal.