trouble launching game through Steam

Macintosh support forum for Eschalon: Book I
Post Reply
Idgy
Pledge
Posts: 1
Joined: November 15th, 2010, 10:06 am

trouble launching game through Steam

Post by Idgy » November 15th, 2010, 10:10 am

Not sure if this is best directed at Basilisk support or Steam support, so I'm trying both.

I purchased and downloaded Eschalon Book I on my MacBook, but I'm unable to launch the game. After I click on "Play" in my Games Library, a small Steam window appears, titled "Eschalon: Book I - Steam", with the message "Preparing to Launch Eschalon: Book I.."

This window closes with no further messages or error codes, and I'm left at the Eschalon page in my Steam games library.


Here are my system details:

OS X Version 10.5.8
MacBook Model 3,1
Steam Client Application built Jun 30 2010 at 14:43:46
Steam API v009
Steam Package versions: 1278013843 / 1278013843

I've tried the following corrective actions:
re-starting Steam
re-starting Steam in offline mode
verifying integrity of game cache
applying all OS X software and firmware updates and reboot
deleting local content and re-downloading the game

None of the above steps fixed the issue. Any suggestions on what else I could try?

User avatar
BasiliskWrangler
Site Admin
Posts: 3789
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: trouble launching game through Steam

Post by BasiliskWrangler » November 18th, 2010, 6:40 pm

Does your computer have a PPC or Intel processor?
See my ramblings and keep up with the latest news on Twitter & Facebook.

User avatar
CrazyBernie
Captain Magnate
Captain Magnate
Posts: 1442
Joined: November 29th, 2007, 1:11 pm

Re: trouble launching game through Steam

Post by CrazyBernie » November 20th, 2010, 2:13 am

MacBooks are all made with Intel chips, good sir. The Model 3,1 runs a Intel Core 2 Duo @ 2+ GHz, and of course the horrendous Intel GMA graphics.

BillyTheFish
Pledge
Posts: 1
Joined: July 19th, 2011, 2:01 pm

Re: trouble launching game through Steam

Post by BillyTheFish » July 19th, 2011, 2:06 pm

Hi,
I'm having the same problem on a dual core 2007 imac (1600 Ati card). I'm running 10.5.8. Hope this helps resolve this as I'm itching the play the game.
BtF

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests