More on the DELDIR Error...

Macintosh support forum for Eschalon: Book I
Post Reply
User avatar
Posts: 1684
Joined: August 31st, 2008, 11:07 am
Location: Southern California

More on the DELDIR Error...

Post by IJBall »

OK so I was just starting up my first new Book I playthrough in about 2 years - but when I just tried to save my game, only the Quicksave slot showed up anything in it, and when I tried to save in to the blank (not "EMPTY", but blank) slot #2, I got the infamous "Can't save - DELDIR error" (or words to that effect).

Well, it turns out I had earlier moved the "slot2" and "slot10" folders to another folder (to "back them up" effectively, while attempting to leave two new "EMPTY" slots in their place).

But I had not created new, empty "slot2" or "slot10" folders in their place.

This is what caused the DELDIR error.

Once I created new, empty "slot2" and "slot10" folders, my other old Savegames appeared again in slots #3-9, and I was able to save my character in the newly "EMPTY" slot #2.

Moral of the story is: if you get a DELDIR error in Book I, first check to make sure that you have folders for "slot1" through "slot10" present in the "Eschalon Book 1 Saved Games" folder.

Post Reply