Page 1 of 1

No Sound in Lubuntu 16.10 [SOLVED]

Posted: March 5th, 2017, 12:05 am
by luiz4vn
Hey guys, the game is running just fine, but the sound isn't coming out, I already did a long research on how to solve this problem, but seems like I'm pretty noob at Linux, I've tried to run padsp on terminal, but nothing seems to work out. Sorry for being dumb, can you help me solve this problem, step-by-step? :oops:

Re: No Sound in Lubuntu 16.10

Posted: March 5th, 2017, 1:21 am
by SpottedShroom
You say you tried to run padsp. Can you say more about how that didn't work out?

Re: No Sound in Lubuntu 16.10

Posted: March 5th, 2017, 9:01 am
by blatherbeard
at least you can use linux, i can barely use windows ;)

Re: No Sound in Lubuntu 16.10

Posted: March 5th, 2017, 11:31 am
by luiz4vn
SpottedShroom wrote:
March 5th, 2017, 1:21 am
You say you tried to run padsp. Can you say more about how that didn't work out?
I've opened the terminal (ctrl+alt+t) and tried to run the game with the following code:

Code: Select all

$ padsp ./eschalon_book_1
and then I received this error: /usr/bin/padsp: 84: exec: ./eschalon_book_1: not found

I tried to put the eschalon_book_1 file into /usr/bin/padsp but I couldn't... I'm confused. :(

Re: No Sound in Lubuntu 16.10

Posted: March 6th, 2017, 5:15 pm
by SpottedShroom
Sounds like you're not in the right directory when you run padsp. Try this:

1. Figure out where your eschalon_book_1 executable is. The path will probably start with "/home/<your user>"
2. Run a terminal program
3. At the prompt, type "cd /<path from step 1> and then enter. If all goes well, you should get no response. If you get an error instead, you may have mistyped the path or you may have the wrong one.
4. Type "padsp ./eschalon_book_1" and then enter
5. If the game runs, see if you have sound. If it doesn't, you may have the wrong path.

Re: No Sound in Lubuntu 16.10

Posted: March 6th, 2017, 5:18 pm
by SpottedShroom
blatherbeard wrote:
March 5th, 2017, 9:01 am
at least you can use linux, i can barely use windows ;)
Nobody can use Windows more than barely ;)

Re: No Sound in Lubuntu 16.10

Posted: March 6th, 2017, 9:03 pm
by luiz4vn

Code: Select all

luiz4vn@luiz4vn-Aspire-V5-571:~/PlayOnLinux's virtual drives/Eschalon Book I/game$ padsp ./"Eschalon Book I"
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
What does it mean?

I also tried the following code after trying this tutorial...http://www.ideatrash.net/2014/06/fix-pa ... 64-bit.htm

Code: Select all

luiz4vn@luiz4vn-Aspire-V5-571:~/PlayOnLinux's virtual drives/Eschalon Book I/game$ padsp_32 ./"Eschalon Book I"
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored. 
I believe the error persisted because I couldn't follow these steps:
  • Use your favorite text editor (as root!) to edit padsp_32. You will change the two places that say

    /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so

    to

    /usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so
I cant find padsp_32 file... So you think this is going to solve?

Re: No Sound in Lubuntu 16.10

Posted: March 7th, 2017, 3:59 pm
by SpottedShroom
Try this:

From the terminal, run "sudo apt install pulseaudio-utils:i386". You'll need to enter your password

Now you should have /usr/lib/i386-linux-gnu/pulseaudio/libpulsedsp.so and your padsp should refer to that rather than /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsedsp.so

If you ever need padsp to work with a 64-bit program, run "sudo apt install pulseaudio-utils" to get the original version back.

Re: No Sound in Lubuntu 16.10

Posted: March 7th, 2017, 4:13 pm
by luiz4vn
From the terminal, run "sudo apt install pulseaudio-utils:i386". You'll need to enter your password
It worked! Gratitude, love you <3