Locks up X at Launch Menu

Linux support forum for Eschalon: Book I
Post Reply
iggames
Pledge
Posts: 2
Joined: November 17th, 2008, 5:55 pm

Locks up X at Launch Menu

Post by iggames » November 17th, 2008, 6:24 pm

After launching ./Eschalon_Book_I, a black window titled "Launch Menu" appears and my X session hangs. That is, the screen is still visible and I can move my mouse around, but nothing responds to mouse clicks or key presses.

My /var/log/Xorg.0.log.old file ends with the following (hundreds of times):

Code: Select all

[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.
I have a Lenovo Thinkpad T61 with the Intel GM965 controller, running an up-to-date Ubuntu Intrepid (8.10). Has anyone been able to run this game with a similar configuration?

Thanks,
Jeremy

Some stats:

Code: Select all

$ uname -a
Linux Gecko 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 01)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b6)

Hawkwind
Steward
Posts: 62
Joined: December 20th, 2008, 7:11 pm
Location: Salt Lake City, UT -- Or 35,000ft in the air on a Delta Jet.

Re: Locks up X at Launch Menu

Post by Hawkwind » December 29th, 2008, 9:47 pm

If it's any consolation, I have the exact same configuration (Lenovo T61 with that crappy Intel video card, same version of Ubuntu) and it's doing the exact same thing to me -- I'm running the 64-bit version of Ubuntu, however. I'm mildly curious (as in, "not enough to reload my OS") as to whether or not this problem plagues the 32-bit version of the OS. Something tells me that if we had an ATI or Nvidia, this wouldn't be happening...64-bit drivers for the Intel card seem to be hard to come by.

I think it's the same problem as posted viewtopic.php?f=11&t=1951 but not 100% sure.

Hawkwind
Steward
Posts: 62
Joined: December 20th, 2008, 7:11 pm
Location: Salt Lake City, UT -- Or 35,000ft in the air on a Delta Jet.

Re: Locks up X at Launch Menu

Post by Hawkwind » January 2nd, 2009, 5:11 pm

Maybe this is a sad sign of no social life, but....

So I also have a T61p (the widescreen version of the T61) with an Nvidia Quattro FX570M in addition to the T61 with the Intel GM in it. Over the new years holiday I got bored (since we had to take a mandatory vacation...) and loaded the same x32-64 Ubuntu and allowed it to tell me about the "non-free" Nvidia driver, loaded it up and the game worked absolutely fine. With that, I'd say it's the dang Intel graphics module in our T61's. In my case, that's problem solved, however that doesn't help the poor unfortunate souls who's work doesn't require -- and fund -- having a boatload of laptops and Macs laying around the apartment to tinker with. And no, I'm not going to tell you where I live.

It is interesting to note, however, that the driver that comes with Intrepid Ibex is supposedly "supported" by the Ubuntu folks and the community, and is pretty much identical to what the Intel folks posted as the open-source driver for the adapter. Maybe it would be a good idea for you to post something on their forums and see what they come up with. The other thing that leads me to believe the display adapter driver is so much lizard guano is that I was running the OpenGL screensavers on the T61 and the thing kept locking up. Switched it to blank and it's been fine ever since. I'd say this isn't a Basilisk Games support issue as much as an Ubuntu one. Or, more specifically, an Intel one.

iggames
Pledge
Posts: 2
Joined: November 17th, 2008, 5:55 pm

Re: Locks up X at Launch Menu

Post by iggames » April 19th, 2009, 1:50 pm

For what it's worth, I just tried the new version (1.0.5) this morning with Ubuntu Jaunty Jackalope (beta), and it loads and plays just fine. :D

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests