gentoo x86_64 difficulties [solved]

Linux support forum for Eschalon: Book I
Post Reply
Posts: 1
Joined: March 2nd, 2009, 11:13 pm

gentoo x86_64 difficulties [solved]

Post by nmeagent » March 2nd, 2009, 11:44 pm

Hello all -- I purchased the latest linux version of book 1 last night and I cannot get seem to get the bloody thing working well enough to actually play. If I run the binary, select full-screen mode, and click start, I get an immediate segfault. Bang. If I select windowed mode instead, I do see the title screen. However, I literally get 1 FPS. Clicking in the settings selection dialog is noticeably sluggish, as well. I have yet to be able to get past that title screen...

Code: Select all

john@jabberwock ~/eschalon_book_1 $ uname -a
Linux jabberwock 2.6.26-gentoo-r3 #1 SMP PREEMPT Sun Nov 30 23:48:45 EST 2008 x86_64 Intel(R) Xeon(R) CPU X3350 @ 2.66GHz GenuineIntel GNU/Linux
I'm running a quad-core Xeon with 4GB of RAM and an nvidia GeForce 8600 GT; I don't think I have a problem here. I am using the proprietary nvidia drivers (180.35). I am running openbox as a window manager with no desktop 'environment' to muck up the works. The X11 Composite extension is disabled entirely (not that I have a decent compositor besides xcompmgr anyway). 3D acceleration is working fine, for what that's worth (not much).

I don't have any performance problems with any of the half-dozen or so 32-bit native linux games that I have installed currently or in the past. If I had to guess, I'd say I'm having some bizarre library issues. However, I can't figure out what could be causing this horrible performance. I had thought that my 32-bit libs were in order as I've installed all of the requisite compatibility packages, including that which includes (which a couple of people seem to think is a dependency).

Here's what ldd tells me:

Code: Select all

john@jabberwock ~/eschalon_book_1 $ ldd Eschalon\ Book\ I =>  (0xf7f4c000) => /usr/lib32/ (0xf7e46000) => //usr/lib32/opengl/nvidia/lib/ (0xf7d8c000) => /usr/lib32/ (0xf7d0b000) => /usr/lib32/ (0xf7d05000) => /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.3/32/ (0xf7c13000) => /lib32/ (0xf7bed000) => /lib32/ (0xf7bdf000) => /lib32/ (0xf7bc7000) => /lib32/ (0xf7a84000) => /lib32/ (0xf7a80000) => /usr/lib32/ (0xf7a7b000) => /usr/lib32/ (0xf7a75000) => //usr/lib32/opengl/nvidia/lib/ (0xf6b5e000) => //usr/lib32/opengl/nvidia/lib/ (0xf6b5c000) => /usr/lib32/ (0xf6b4d000)
        /lib/ (0xf7f4d000)
It seems to be picking up most of these from /usr/lib32 or /lib32 as I'd expect. It also seems to be asking for (and finding) libstdc++ v.6.

Any ideas? Is there something fundamental that I'm missing here? Let me know if you need any other information as I'm sure I neglected to mention something.

Nevermind. Version 180.35 of the proprietary nvidia drivers was masked after I had installed it. Everything works fine so far with 180.29.

Posts: 2
Joined: September 10th, 2011, 1:02 pm

Re: gentoo x86_64 difficulties [solved]

Post by dahoste » September 10th, 2011, 1:11 pm

Just wanted to add a note here about my gentoo x86_64 issues, and eventual resolution.

When attempting to run eschalon_book_1, I was getting the message:

Code: Select all has no version info available
Which evidently was a known issue with the multilib environment created by sys-libs/libstdc++-v3. See this gentoo bug.

I had been unable to get any workaround to succeed, so I just let the situation idle for awhile. A recent update to sys-libs/libstdc++-v3 became available (v3.3.6-r1), and after installing it, voila, eschalon_book_1 runs without complaint, and I've experienced no other issues thus far.

So.. happy ending! I'm a little late to the party, but I can finally play Eschalon Book 1 (I don't maintain an x86 linux env anymore, and have quit windows gaming almost entirely).

Thanks to Basilisk for supporting linux, and thanks to the gentoo crew for supporting multilib on amd64!

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests