Weird bug with Eschalon sound.

Linux support forum for Eschalon: Book I
Post Reply
User avatar
skaldicpoet9
Initiate
Posts: 7
Joined: April 13th, 2009, 12:34 am

Weird bug with Eschalon sound.

Post by skaldicpoet9 » April 23rd, 2009, 5:02 pm

So lately whenever I launch Eschalon it launches without sound. I altered the config file to enable openal but I suppose that I don't have it installed. However, when I change the value back to default the sound works fine again, no problems. I am running it on Linux btw. Is there anything I could do besides altering the config file every time I launch Eschalon?

Tyranthraxus
Steward
Posts: 76
Joined: May 17th, 2009, 4:15 pm
Location: Valjevo Castle, Phlan

Re: Weird bug with Eschalon sound.

Post by Tyranthraxus » May 17th, 2009, 4:32 pm

skaldicpoet9, I had a similar weird problem with sound, maybe this may be of help.
I was running the game on Mandriva Power Pack 2008, and my game also always started with no sound.
The way I got round it, seemed to be a problem with KDE hogging the sound system too long before releasing it back to the system.
If I left my computer idle for a long time, after startup, the game would usually start with sound. Looking in KDE`s control centre, I found an option to change the amount of time that KDE waited before releasing the sound. I dropped this time back considerably, and found that most times, Eschalon would then start with sound working, although it still appears best to wait a minute or two after Linux loaded, to guarantee this.
Hope this helps, I don`t know whether this was peculiar to a particular release of KDE, or a more general problem, but this cured it for me.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests