Page 1 of 1

No Sound?

Posted: May 20th, 2009, 11:30 pm
by theidiotthatisme
Hi, I'm running the demo on Debian Gnu/Linux Lenny (5.0) and didn't realize it until about an hour in to the game, that I didn't have any sound! (I blame the TV going in the background for not noticing...) Has anyone else had problems with audio? I saw a previous forum post about a configuration problem in KDE, but I run regular old Gnome on Debian.

Re: No Sound?

Posted: May 21st, 2009, 1:50 am
by theidiotthatisme
I just wanted to add, that when I open up the cfg file, there is absolutely no options regarding sound, whether default or openal like I've seen in some of the previous forum posts. When I tried to add a line that was used an example from another post and relaunch the game, the cfg file is completely reset on launch of the game. Is this normal?

Re: No Sound?

Posted: June 1st, 2009, 9:42 am
by lazyl
You need to launch the game with a wrapper that routes the sound through whatever sound daemon you're using. I think pulseaudio is the default sound daemon in ubuntu, in which case the wrapper is called 'padsp':

Run "padsp ./Eschalon_Book_I" and you should have sound.

But if you're not using pusleaudio then that won't work. Just check the list of tools that come with whatever sound system you have and you should find one that does the job. I actually use esound (Enlightened Sound Daemon) myself and it's version of this script is called 'esddsp'.

Re: No Sound?

Posted: October 14th, 2009, 8:54 am
by mczolton
I seem to be experiencing a similar problem running Eschalon: Book I (Demo) under Xubuntu 9.04. I don't have Pulse audio installed, and frankly, I am somewhat ignorant when it comes to gaming on Linux. That is to say, I don't really understand how audio works in Xubuntu.

I know that I can play back WAV and MP3 files (among others), and that my sound card is listed as "HDA Intel (Alsa Mixer)", and is functioning correctly. I am not familiar with the various sound wrappers.

Any thoughts? Can I provide you with more information? Please let me know.

Thank you!

Re: No Sound?

Posted: October 14th, 2009, 9:36 am
by mczolton
Never mind. I installed Pulse Audio and used the wrapper method. Sound now works, but I get a segmentation fault when starting a new game. Removing the save game folder solves the problem, but the next time I try to start a new game, I get the segmentation fault again. Certainly a topic for another thread, but I thought I would mention it anyway.


Re: No Sound?

Posted: December 17th, 2009, 4:18 am
by torturedutopian
Same issue here, it seems BlitzMax uses OSS by default which it seems needs to lock the audio device (?). It also affects Charlie's Linux games ( but he'll fix them so they uses ALSA.

It would be cool if some devs could forward this to the BlitzMax developers. It seems pretty outdated to still default to OSS in 2009 :-)

It's not that annoying for me (to use padsp), but Linux newbies may be unsettled :)

Re: No Sound?

Posted: December 17th, 2009, 10:56 am
by BasiliskWrangler
Book II will have a launch window that will scan your system for various sound drivers, allowing you to choose which one to use. I am curious as to how much this will help you Linux folks.

Re: No Sound?

Posted: February 5th, 2010, 5:36 pm
by pal.illes
That will certainly be very nice! :D

Re: No Sound?

Posted: February 16th, 2010, 8:50 pm
by Greybeard
Using padsp worked fine for me on Ubuntu 9.10 Karmic, but it is odd that this game still uses OSS, as Alsa (libasound) has been the most common way to play sound on Linux-based systems for many years. Playing sound via libasound is probably the best approach these days, since it can work well for both those who use Pulseaudio and those who don't, at least if one sticks with the safe Alsa subset. Using the safe Alsa subset would mean that the vast majority of users wouldn't have to know anything about it, as it would just work for them.

Re: No Sound?

Posted: March 31st, 2010, 4:06 pm
by Ulexus
Simple workaround:
- install aoss (part of the alsa-oss package on Debian-derived distributions)
- when running the game, prefix it with aoss

As others have said, this game perplexingly uses the years-obsolete OSS audio implementation. Any modern kernel uses ALSA. aoss is a wrapper which provides a more complete OSS environment to OSS-based programs than comes simply with the kernel-based ALSA-OSS implementation.

This _may_ not be necessary if you have a very simple ALSA config (like the default), but I use dmix and a number of other plugins, and this is the only way (without running another sound mixer) I had to get sound working.

If you are using PulseAudio, esd, arts, or any other sound mixer, you would want to use its wrapper (if it exists) for this instead.

Re: No Sound?

Posted: April 1st, 2010, 1:33 am
by torturedutopian
Ulexus : yep... padsp for pulseaudio.

Re: No Sound?

Posted: June 4th, 2010, 12:59 am
by lockjaw
hi folks,

I'm having no luck with either aoss:

ERROR: object '/usr/lib/' from LD_PRELOAD cannot be preloaded: ignored.

or padsp

ERROR: object '' from LD_PRELOAD cannot be preloaded: ignored.

I've been googling that LD_PRELOAD message and can't get a handle on what's going on. strace shows the library being opened ! then it gives the LD_PRELOAD error.

Library is definitely there.


Linux windy 2.6.32-3-amd64 #1 SMP Wed Feb 24 18:07:42 UTC 2010 x86_64 GNU/Linux

Re: No Sound?

Posted: June 4th, 2010, 12:39 pm
by wuji
may be some incompatibility? LD_PRELOAD loads a certain library first that may override functions from other libraries, I'd asume that libaoss overrides certain function for oss sound with their own.

You may try to load snd-pcm-oss to get the oss devices. this worked for me but you will have to shutdown anything that grabs your soundcard, sound daemons, music players etc.

I've just finished(again) book 1 on debian amd64. I've had problem with version 1.04, because there wasn't correct libopenal installed and I had to download the one from i386 etch and put it in the eschalon directory. version 1.05 is supposedly recompiled with newer libraries and this wasn't needed anymore (my guess is that it uses libopenal1 now but I didn't check).

Re: No Sound?

Posted: June 5th, 2010, 10:39 am
by lockjaw
Here's the solution to my sound issues.

First big round of applause to the Ubuntu forum user Kilz who created this 32-bit library: ... _amd64.deb

I simply downloaded and installed using "dpkg --install"

However I find that I also have to do the following:

export LD_PRELOAD=/usr/lib32/

Then I can run the game normally from the command line and all is well. Here's the strange part. Once you have exported the above variable you'll see this message all the time:

ERROR: object '/usr/lib32/' from LD_PRELOAD cannot be preloaded: ignored.

Which is very strange because the sound works just fine. And no, using "aoss" to run the game does not seem to work.


Re: No Sound?

Posted: July 4th, 2012, 9:19 pm
by Dhuend
I got no sound when running EB1, pretty much similar to lockjaw's message of LD_PRELOAD after trying the padsp command:
ERROR: object '' from LD_PRELOAD cannot be preloaded: ignored.
I figured out that my system (Fedora 16 x64 bits) uses Pulseaudio, and the pre-installed drivers should be the 64 bit ones. Confirmed this by typing:

Code: Select all

yum list *pulse*
A lot of pulse x86_64 llibraries appeared after that command.

So I fixed the issue installing the 32 bit pulseaudio drivers, just typing:

Code: Select all

yum install pulseaudio*i686
The game runs perfectly now. By the way, I have to keep "Default" on my eschalon.cfg file (OpenAL doesn't works after this fix).