Intermittent slow-down

Linux support forum for Eschalon: Book I
Post Reply
rah
Pledge
Posts: 4
Joined: June 17th, 2010, 1:10 pm

Intermittent slow-down

Post by rah » June 17th, 2010, 1:21 pm

Hi there,

At times, the game runs extremely slowly. The interface becomes extremely sluggish. This manifests in different ways, for example mouse clicks have no effect and the mouse button has to be held down for it to register or typing names for save-game slots is near impossible as the letters either don't appear or appear a number of seconds after they've been typed.

These problems are intermittent but they do occur often and are very frustrating. Is there anything I can do to stop this happening or is it simply bad programming of the game engine?

Robert

User avatar
Kreador Freeaxe
Major General
Major General
Posts: 2378
Joined: April 26th, 2008, 3:44 pm

Re: Intermittent slow-down

Post by Kreador Freeaxe » June 17th, 2010, 3:26 pm

It may be a conflict of some stuff in the game with some stuff in your particular Linux setup. If you give specifics, including which version of Book I you're running, some of the Linux gurus wandering these forums can probably help you.
---

Kill 'em all, let the sysadmin sort 'em out.

rah
Pledge
Posts: 4
Joined: June 17th, 2010, 1:10 pm

Re: Intermittent slow-down

Post by rah » June 17th, 2010, 4:30 pm

Kreador Freeaxe wrote:which version of Book I you're running
I'm running v1.05 apparently.

rah
Pledge
Posts: 4
Joined: June 17th, 2010, 1:10 pm

Re: Intermittent slow-down

Post by rah » June 21st, 2010, 6:16 am

Kreador Freeaxe wrote:If you give specifics, including which version of Book I you're running, some of the Linux gurus wandering these forums can probably help you.
I've given the version of Book I that I'm running and none of the Linux gurus are helping me. What other specifics do I need to give?

User avatar
Kreador Freeaxe
Major General
Major General
Posts: 2378
Joined: April 26th, 2008, 3:44 pm

Re: Intermittent slow-down

Post by Kreador Freeaxe » June 21st, 2010, 7:52 am

rah wrote:
Kreador Freeaxe wrote:If you give specifics, including which version of Book I you're running, some of the Linux gurus wandering these forums can probably help you.
I've given the version of Book I that I'm running and none of the Linux gurus are helping me. What other specifics do I need to give?
This being at the bottom of the forum, I'm sure it's just not getting much traffic. Anyway, you need to let people know what version of Linux you're running on what kind of hardware. There are so many possible builds that just knowing that you're using the latest version of Book I won't tell anyone what could be giving you performance issues.
---

Kill 'em all, let the sysadmin sort 'em out.

rah
Pledge
Posts: 4
Joined: June 17th, 2010, 1:10 pm

Re: Intermittent slow-down

Post by rah » June 21st, 2010, 8:24 am

Kreador Freeaxe wrote:what version of Linux you're running on what kind of hardware.
I get slowdowns using Linux 2.6.33 and 2.6.34 with radeon KMS and UMS, with X and xf86-video-ati from both Debian and the latest git. This is on a Core 2 Duo E8400 3.0GHz x86_64 machine with 4GB of RAM and a Radeon 4850 graphics card.

User avatar
CycyX
Fellowcraft Apprentice
Posts: 48
Joined: May 26th, 2010, 7:54 am
Location: France
Contact:

Re: Intermittent slow-down

Post by CycyX » June 21st, 2010, 9:58 am

Have you tried the fglrx driver?

I know, it will taint your kernel and corrupt your soul, but you will get better OpenGL performances using it.

Slammer64
Apprentice
Posts: 22
Joined: June 7th, 2010, 1:09 pm
Location: The Ozark Mountains of Missouri

Re: Intermittent slow-down

Post by Slammer64 » June 21st, 2010, 12:31 pm

Do you have direct rendering enabled and is your user added into the video group?
Somewhere, just out of sight, the Penguins are gathering!

john
Fellowcraft Apprentice
Posts: 40
Joined: July 3rd, 2009, 9:28 pm

Re: Intermittent slow-down

Post by john » June 22nd, 2010, 10:56 am

Have you tried strace or top to (a) see if the program is utilizing 100% of the processor and/or is swapping. I find it hard to believe that any modern system with inexpensive 2d framebuffer would have issues with this program. Conversely have you tried the windows version with wine ?

Anyways I ran a few minutes of the demo under wine (ubuntu 8.04; which is fairly old) ++ and it seemed to run fine (killed first rat and chatted with blacksmith).

I realize you are having problems with native linux version but I can't test that (glib issue).
--
the machine i use has a dumb 2d buffer (50$ nvidia card; forget the model #) and 1.5ghz quad proc. (don't let the quad scare you as the program doesn't use that much cpu)
--
should mention two issues: screen resolution has to be manually reset after exiting; doesn't seem to render in window mode which is a bit of a bummer; didn't try different graphic options et all to see if this second issue could be resolved don't have time right now.

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Intermittent slow-down

Post by SpottedShroom » January 29th, 2011, 6:48 pm

orther11 wrote:hi,
friends
i am so happy
and new one here.

thanks
This is the weirdest spam account...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest