Slow walking movement in Ubuntu 11.04

Linux support forum for Eschalon: Book I
Post Reply
zeddyfree
Pledge
Posts: 2
Joined: July 3rd, 2011, 1:24 am

Slow walking movement in Ubuntu 11.04

Post by zeddyfree » July 3rd, 2011, 1:39 am

Hi Guys,

Got the sound working at least when running the following command from the terminal and the directory of book I:
"padsp ./Eschalon_Book_I"

But the movement of the character is extremely slow. Any idea how to fix this?

Some information about my system:
I have Ubuntu 11.04, an Ati HD5750. I do not use the fglrx proprietary driver (and I rather not want too, because it screws up automatic v-sync and the splash screen. The open source drivers since Ubuntu 11.04 (new kernel?) are very good for watching video)

glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD JUNIPER
OpenGL version string: 2.1 Mesa 7.10.2
OpenGL shading language version string: 1.20
OpenGL extensions:

glxinfo | head
name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,



I have tried adding "Option "AccelMethod" "uxa" "
to a newly made xorg.conf, as another post mentioned. It did not work. Then I tried installing fglrx, something went wrong and broke my system.
I re-installed Ubuntu.....

zeddyfree
Pledge
Posts: 2
Joined: July 3rd, 2011, 1:24 am

Re: Slow walking movement in Ubuntu 11.04

Post by zeddyfree » July 4th, 2011, 4:54 am

Tried to install the ati-drivers and this time it worked. It solved the slowness problem.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest