Page 1 of 1

can't save - [DelDir] bug

Posted: November 13th, 2010, 11:47 am
by kuliksco
I played through the game the first time and would sometimes see the attached screenshot with the message:

The system encountered an error: [DelDir] Try to save your game again.

When this would happen the slot# folder would get deleted from my save game directory and I would have to manually copy over a backup and try again. Usually after failing a few more times and a minute later I finally got my game saved.

Now, I just started a new character and this is happening literally every time I save. Also, I end up having to recreate the save directory usually 4-5 times for it to work this time.

I am running the Steam version with Windows 7 64 bit. This bug is totally ruining this game and I think I'm going to put it on the shelf until it's fixed because of it.

I am not using UAC and have manually set the default Save path to have read/write for Everyone.

I searched the forums and see many people have this issue with Book 1 and 2 but there is no fix as of yet besides the temporary workaround.

Can someone please update on the status of this getting fixed? Thanks.

Re: can't save - [DelDir] bug

Posted: November 14th, 2010, 8:13 pm
by dterror
I had the same thing occur with my quicksave slot, however instead of recreating the entire directory by copying all the files into it, I just created a blank directory of the correct name. The next time I tried to save a game to the quicksave, it worked fine and hasn't happened again since then.

Just create a new directory of the correct name, leave it empty, and see if that works for you.

Re: can't save - [DelDir] bug

Posted: November 14th, 2010, 9:53 pm
by kuliksco
i ended up uninstalling from steam and redownloading. i copied over my saved games and everything seems to be running ok for now. fingers crossed!