Doesn't run on Ubuntu Jaunty 64b bit

Linux support forums for Eschalon: Book II
I-hate-captchas
Initiate
Posts: 12
Joined: May 26th, 2010, 6:59 am

Doesn't run on Ubuntu Jaunty 64b bit

Post by I-hate-captchas » May 26th, 2010, 7:49 am

I'm getting this error:

$./eschalon_book_2
./eschalon_book_2: /lib32/libc.so.6: version `GLIBC_2.11' not found (required by ./eschalon_book_2)

I'm trying to figure out what package is missing right now.

Any chance to get a staticallly linked executable btw?

fedon
Initiate
Posts: 7
Joined: May 20th, 2010, 7:00 am

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by fedon » May 26th, 2010, 9:14 am

I can run it on Fedora 64:

Name : glibc-devel
Arch : i686
Version : 2.11.1

I am not sure if it helps. BTW, libstdc++.so.5 is required. It is from some of compat-... packages.

richo123
Pledge
Posts: 1
Joined: May 26th, 2010, 8:40 am

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by richo123 » May 26th, 2010, 9:41 am

I am running it on Ubuntu 10.04 64bit. It sounds as if the game needs a version of that library compiled with gcc 2.11 which Ubuntu 10.04 has but perhaps your (earlier?) distro version does not have.

Elwro
Senior Steward
Posts: 97
Joined: December 25th, 2007, 1:43 pm

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by Elwro » May 26th, 2010, 9:58 am

Same error here on 32bit Ubuntu 9.10. Don't see anything appropriate to install in Synaptic. I won't be upgrading this PC to 10.04 since doing this at my workplace resulted in many errors and losing printing support. (And, in fact, the upgrade procedure is risky - just check the hundreds of issues people report at the official Ubuntu forums.) Is there a glibc 2.11 build for karmic I could use or does it mean no Eschalon 2 for me?

I-hate-captchas
Initiate
Posts: 12
Joined: May 26th, 2010, 6:59 am

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by I-hate-captchas » May 26th, 2010, 10:13 am

Jaunty is on 2.9 and this is probably why it doesn't work. Do I have to upgrade my distro to play? It suxxxx :(

Elwro
Senior Steward
Posts: 97
Joined: December 25th, 2007, 1:43 pm

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by Elwro » May 26th, 2010, 10:30 am

On Karmic, the package responsible is called "libc6", I now think. It's in version 2.10.1 in the repositories. It's in 2.11 for lucid.

http://packages.ubuntu.com/search?keywords=libc6

I'm not sure I should install the lucid version you can download from there, though. The package manager says "Error: Breaks existing package 'libc6-dev' dependency libc6 (= 2.10.1-0ubuntu17)". I guess I could remove e.g. libc6-dev, but I'm not sure It's a wise move. Any help? Limiting your Ubuntu customer group to lucid only doesn't strike me as the wisest choice.

obiwan
Fellowcraft Apprentice
Posts: 52
Joined: October 31st, 2008, 10:59 am

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by obiwan » May 26th, 2010, 11:25 am

libc6-dev is a development package. As long as you do not compile things, it is probably no problem to remove it. However, virtually everything uses libc and installing the lucid binary on karmic may really break things.

glibc /is/ backwards compatible. So if BW would have used an old version of glibc on the compile machine, all would be fine (the newer lib keeps the old ABI around). But by default, the linker will use the newest version of things in glibc. So if this is compiled against glibc2.11, we need glibc2.11, or hack around it.

I am still downloading, so I won't post a workaround yet (I need to try it because it is quite tricky with libc). It would be easier if BW finds an older compile host, or tells the compiler to use an alternate glibc (it is easy with gcc, but I have no idea how this blitz stuff works).

User avatar
TheBuzzSaw
Apprentice
Posts: 36
Joined: May 23rd, 2010, 2:28 pm
Contact:

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by TheBuzzSaw » May 26th, 2010, 11:29 am

Yup. Same issue here. It's such a simple problem, yet it requires BW's intervention to clean up.

I am currently running 9.10 because I am not ready to upgrade to 10.04 yet.
Amateurs practice until they do it right.
Professionals practice until they never do it wrong.

User avatar
BasiliskWrangler
Site Admin
Posts: 3805
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by BasiliskWrangler » May 26th, 2010, 12:56 pm

obiwan wrote:glibc /is/ backwards compatible. So if BW would have used an old version of glibc on the compile machine, all would be fine (the newer lib keeps the old ABI around). But by default, the linker will use the newest version of things in glibc. So if this is compiled against glibc2.11, we need glibc2.11, or hack around it.
TheBuzzSaw wrote:Yup. Same issue here. It's such a simple problem, yet it requires BW's intervention to clean up.
Hold on, there! Here's where I must interject. We use BlitzMax, which is a full-feature language for cross-platform development. The thing is, I have no control over what BlitzMax requires or doesn't require. I write the code, BlitzMax compiles it into a Linux executable. I don't personally import or utilize any libraries for the game itself- all dependencies are because of the compiler.

If there is something inherently wrong with the way BlitzMax builds Linux executables, then I highly recommend some of you Linux gearheads send an email to BRL, the company that produces BlitzMax. Explain to them what needs to be done.

I admit, I am not a Linux guru by any means. I love the OS and use it everyday, but I am not an expert and would not even consider myself a true Linux developer. All I know is the game runs just fine on Ubuntu 10.04 32-bit. I can't guarantee anything beyond that.
See my ramblings and keep up with the latest news on Twitter & Facebook.

User avatar
TheBuzzSaw
Apprentice
Posts: 36
Joined: May 23rd, 2010, 2:28 pm
Contact:

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by TheBuzzSaw » May 26th, 2010, 1:06 pm

I'm pretty sure it's just a simple matter of running the Blitz compiler under an earlier version of Ubuntu. I agree that you probably have little control over what Blitz does, but I highly doubt Blitz carries its own C library around. It just uses whatever your system is currently running.

Compile it under Ubuntu 9.10 or even 9.04 if you can. That should fix everything. Trust me.
Amateurs practice until they do it right.
Professionals practice until they never do it wrong.

User avatar
BasiliskWrangler
Site Admin
Posts: 3805
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by BasiliskWrangler » May 26th, 2010, 1:28 pm

TheBuzzSaw wrote:I'm pretty sure it's just a simple matter of running the Blitz compiler under an earlier version of Ubuntu. I agree that you probably have little control over what Blitz does, but I highly doubt Blitz carries its own C library around. It just uses whatever your system is currently running.

Compile it under Ubuntu 9.10 or even 9.04 if you can. That should fix everything. Trust me.
Ah, I understand. Well I only have one available Linux box here, so I will need to downgrade it back to 9.04. I'll try to get this done in the next day or so.

Thanks for your input!
See my ramblings and keep up with the latest news on Twitter & Facebook.

User avatar
TheBuzzSaw
Apprentice
Posts: 36
Joined: May 23rd, 2010, 2:28 pm
Contact:

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by TheBuzzSaw » May 26th, 2010, 1:34 pm

Rather than outright downgrade, install one of the older versions in VirtualBox! It's a great way to compile stuff. For instance, I benefit from VBox by having 32-bit Ubuntu there. That way, I compile 64-bit binaries in my "main" OS, and I can compile necessary 32-bit binaries in my VBox. You don't need to worry about the 32/64 issue since you're using Blitz, but it'd probably be a lot easier to just throw an older Ubuntu into VBox than to attack your currently running system.
Amateurs practice until they do it right.
Professionals practice until they never do it wrong.

ridcully
Initiate
Posts: 18
Joined: December 23rd, 2007, 1:50 pm

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by ridcully » May 26th, 2010, 3:44 pm

i would like to second that. use VirtualBox to get a bare system for building up and running. with the OpenGL support that wraps the native driver you can even run the game at close to full speed of your primary system. There are also ways to make the same thing happen using a chroot environment - but it is usually don't worth the hastle.

just for the files: i get the same problem with gentoo. i will try to unmask some lib32 stuff as my colleague from work told me, that he got it running.

wuji
Apprentice
Posts: 28
Joined: January 9th, 2008, 11:28 pm

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by wuji » May 26th, 2010, 7:32 pm

so can we look forward to the recompiled version or should I start installing the chroot?:)

User avatar
BasiliskWrangler
Site Admin
Posts: 3805
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Doesn't run on Ubuntu Jaunty 64b bit

Post by BasiliskWrangler » May 26th, 2010, 7:36 pm

I will definitely recompile the game, but it might not be until next week. I have an exceptionally long list of "must do" action items to finish before this weekend (this is a holiday weekend for those of us in the US).

I can't promise that I will have time to do this before this weekend, so most likely this will be next week.
See my ramblings and keep up with the latest news on Twitter & Facebook.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests