Sound issues

Linux support forums for Eschalon: Book II
fedon
Initiate
Posts: 7
Joined: May 20th, 2010, 7:00 am

Sound issues

Post by fedon » May 26th, 2010, 9:20 am

Just for some info. There is no pulseaudio driver in this game. So, to run it with sound I use padsp wrapper.
# padsp eschalon_book_2 <enter>

Good luck!

User avatar
TheBuzzSaw
Apprentice
Posts: 36
Joined: May 23rd, 2010, 2:28 pm
Contact:

Re: Sound issues

Post by TheBuzzSaw » May 26th, 2010, 12:15 pm

PulseAudio is the worst thing that ever happened to Linux.
Amateurs practice until they do it right.
Professionals practice until they never do it wrong.

mack
Pledge
Posts: 3
Joined: May 29th, 2010, 12:45 pm

Re: Sound issues

Post by mack » May 29th, 2010, 12:48 pm

Hi, I'm pretty much a novice when it comes to linux but spent a few hours last night setting things up. I unmuted my headset audio with alsamixer and when I read from /proc/asound/modules my first device is my headset.

Sound works in VLC, chromium (from youtube) and Heroes of Newerth. I have no idea what I need to do in order to have sound work. When I click to play the demo it's set by default on null and I tried *FreeAudio and FreeAudio OpenSound System with no luck.

Any help would greatly be appreciated.

regnak90
Initiate
Posts: 5
Joined: May 29th, 2010, 2:25 pm

Re: Sound issues

Post by regnak90 » May 29th, 2010, 2:32 pm

Why didn't you try the others ?
OpenAL works for me.

Elwro
Senior Steward
Posts: 97
Joined: December 25th, 2007, 1:43 pm

Re: Sound issues

Post by Elwro » May 29th, 2010, 2:44 pm

"The others"? I, for one, only see "FreeAudio", "FreeAudio OpenSound System" and "None" in the sound settings menu. (I'm not having problems anymore but I'm just curious whether people with different systems have more options...)

mack
Pledge
Posts: 3
Joined: May 29th, 2010, 12:45 pm

Re: Sound issues

Post by mack » May 29th, 2010, 3:07 pm

Same here, there is no OpenAL option for me. I tried each item on the list with no luck.

regnak90
Initiate
Posts: 5
Joined: May 29th, 2010, 2:25 pm

Re: Sound issues

Post by regnak90 » May 30th, 2010, 10:59 am

mack wrote:Same here, there is no OpenAL option for me. I tried each item on the list with no luck.
Well then maybe installing OpenAL would help.

Elwro
Senior Steward
Posts: 97
Joined: December 25th, 2007, 1:43 pm

Re: Sound issues

Post by Elwro » May 30th, 2010, 12:16 pm

Well, I checked using synaptic and I have OpenAL installed. Other games, e.g. Penumbra, use it without any problems. Eschalon doesn't seem to see it.

mack
Pledge
Posts: 3
Joined: May 29th, 2010, 12:45 pm

Re: Sound issues

Post by mack » May 30th, 2010, 7:25 pm

Figured out what I had to do =P. I had to run aoss. I read a little about the OSS compatibility layer in ALSA.

regnak90
Initiate
Posts: 5
Joined: May 29th, 2010, 2:25 pm

Re: Sound issues

Post by regnak90 » May 31st, 2010, 6:28 am

That is weird, Eschalon support Alsa through OpenAL.
But it's good to see that you have the sound now :)

zeland
Initiate
Posts: 6
Joined: July 2nd, 2010, 1:15 am

Re: Sound issues

Post by zeland » July 2nd, 2010, 1:31 am

Eschalon seems to looking for libopenal.so. Some distros may use different names such as Fedora 13 uses libopenal.so.1 (note the .1). Just symlink your current openal library as libopenal.so and things should work.

fledermaus
Pledge
Posts: 1
Joined: July 2nd, 2010, 5:45 pm

Re: Sound issues

Post by fledermaus » July 2nd, 2010, 6:08 pm

There are two possible (likely) issues with sound here:

eschalon b2 might be looking for libopenal.so instead of libopenal.so.X (where X is the major version) - this can be fixed by installing the -dev or -devel package (or your distribution's equivalent)

--

You might be on a 64 bit system, in which case the 64 bit libraries will be of no use to you as the binary is 32 bit: If you're lucky, there will be a 32 bit package (lib32SOMETHING or similar) for you to install.

If not,you can grab the 32 bit package for your distro instead, unpack it somewhere, and run (for example):

cp libopenal.so.1 ~/lib32
LD_LIBRARY_PATH=~/lib32 /eschalon_book_2

Arno
Pledge
Posts: 2
Joined: July 22nd, 2010, 8:38 pm

Re: Sound issues

Post by Arno » July 22nd, 2010, 8:42 pm

zeland wrote:Eschalon seems to looking for libopenal.so. Some distros may use different names such as Fedora 13 uses libopenal.so.1 (note the .1). Just symlink your current openal library as libopenal.so and things should work.
I am using Fedora 13 and I have no sound while playing. However you post gave me some hope! So next question : how do you symlink openal to libopenal.so ? I have no clue how to do that, my unix knowledge being limited. Thank you!

zeland
Initiate
Posts: 6
Joined: July 2nd, 2010, 1:15 am

Re: Sound issues

Post by zeland » July 23rd, 2010, 7:51 pm

Code: Select all

ln -s /usr/lib/libopenal.so.1 /usr/lib/libopenal.so

Arno
Pledge
Posts: 2
Joined: July 22nd, 2010, 8:38 pm

Re: Sound issues

Post by Arno » July 24th, 2010, 4:10 pm

Zeland thank you! I have a full list of different sound system aside FreeAudio and music+sound in game are working perfectly.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests