Sound issues

Linux support forums for Eschalon: Book II
torturedutopian
Initiate
Posts: 5
Joined: February 6th, 2009, 8:32 am

Re: Sound issues

Post by torturedutopian » October 27th, 2010, 2:08 pm

Hey guys !

Well, I don't know if Pulseaudio is to blame... Dunno... I think it works pretty well nowadays and it has very interesting features...

It *may* also be a drivers issue. Indeed, in my case, I figured out my audio chipset driver, for some reason, didn't seem to support "alsa dmix" : that is to say, that it couldn't mix several audio sources. It couldn't mix, for instance, pulse output with alsa output. I think it explains why, sometimes, I couldn't get sound in alsa apps or OSS apps, or why they were interrupting each others...

*however* if I install in synaptic (in Ubuntu) the "alsa backports modules" everthing works perfectly : alsa & pulse apps mix flawlessly.

--> the problem is that those "backport alsa modules" only seem to exist in Ubuntu. I didn't manage to get them under Archlinux or Debian / Linux Mint Debian Edition...

(in very rare cases, for really old OSS apps, I just have to start them with "padsp" that redirects OSS to Pulse. I guess it's because OSS apps try to lock the hardware ?

---

Just a second remark : Charlie (from Charlies's Games) makes some very cool shmups in BlitzMax for Win/Mac/Linux. I noticed he used the defaults, and by default BlitzMax apps use OSS or ALSA in... exclusive mode (-> no sound if any other app was playing at the same time). Can anyone help him set a non-exclusive mode ? (what a strange idea, I came accross no other alsa app that was forcing this exclusive mode)...

Cheers everyone !
(just registered episode 2, Ubuntu 10.10 AMD64 user at the moment)

jfleming9232
Initiate
Posts: 7
Joined: November 1st, 2008, 1:59 pm

Re: Sound issues

Post by jfleming9232 » June 20th, 2011, 9:20 am

zeland wrote:

Code: Select all

ln -s /usr/lib/libopenal.so.1 /usr/lib/libopenal.so
Thanks!! This worked like a charm.

hero1900
Initiate
Posts: 6
Joined: November 2nd, 2011, 4:40 pm

Re: Sound issues

Post by hero1900 » November 2nd, 2011, 4:55 pm

thx guys i just bought this game and have sound issue and fixed by reading your replies
my regards

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests