Painfully slow on recent computer

Linux support forums for Eschalon: Book II
Post Reply
Bryce
Initiate
Posts: 14
Joined: January 10th, 2008, 10:52 pm
Contact:

Painfully slow on recent computer

Post by Bryce » May 26th, 2010, 7:43 pm

Running Ubuntu 9 on a Thinkpad X200, which should certainly be equal to any 2D RPG, the game is painfully slow. The opening cinematic skips frames and the framerate of the menu screen and game itself is so slow that the cursor is barely controllable and everything lags noticeably. Hardware OpenGL is working, at least for other things (e.g. GLXGears gets over 4000 fps). Planning to upgrade to Ubuntu 10 soon so maybe the problem will go away, but thought you should know.

Bryce
Initiate
Posts: 14
Joined: January 10th, 2008, 10:52 pm
Contact:

Re: Painfully slow on recent computer

Post by Bryce » May 26th, 2010, 8:08 pm

I seem to have at least reduced the problem by turning off Ubuntu's visual effects (thought I already had them disabled)... that may have been the issue; I'll report back.

User avatar
xolotl
Lieutenant
Lieutenant
Posts: 776
Joined: August 21st, 2008, 1:54 pm

Re: Painfully slow on recent computer

Post by xolotl » May 26th, 2010, 9:16 pm

Bryce wrote:Running Ubuntu 9 on a Thinkpad X200, which should certainly be equal to any 2D RPG, the game is painfully slow. The opening cinematic skips frames and the framerate of the menu screen and game itself is so slow that the cursor is barely controllable and everything lags noticeably. Hardware OpenGL is working, at least for other things (e.g. GLXGears gets over 4000 fps). Planning to upgrade to Ubuntu 10 soon so maybe the problem will go away, but thought you should know.
FYI, glxgears is not useful at all as a measure of whether or not you've got hardware acceleration working properly. Far more useful would be the output of:

Code: Select all

glxinfo | grep OpenGL
Or, of course, if you have other games which clearly do use 3D (any FPSes, etc) and they run fine, then clearly your acceleration is enabled and working. glxgears definitely won't tell you, though.

Bryce
Initiate
Posts: 14
Joined: January 10th, 2008, 10:52 pm
Contact:

Re: Painfully slow on recent computer

Post by Bryce » May 26th, 2010, 9:37 pm

Yes, other 3D games using OpenGL work fine, and glxinfo indicates DRI is enabled.

agl
Pledge
Posts: 1
Joined: May 27th, 2010, 9:32 am

Re: Painfully slow on recent computer

Post by agl » May 27th, 2010, 9:38 am

I have the same problem.

I am running Ubuntu Lucid Lynx on a T500 with opengl. Inside the settings I get a value around 37 with high detail and sound turned off and around 29 with low detail.
I ran it in wine before I got the linux version and it was a bit faster.

Because of an update to lucid and with that an update of wine I am no longer able to play it through wine.

Is there a way to make it faster?

regnak90
Initiate
Posts: 5
Joined: May 29th, 2010, 2:25 pm

Re: Painfully slow on recent computer

Post by regnak90 » May 29th, 2010, 2:30 pm

If you want to play Eschalon, you will have to use the proprietary graphic stack, which means that you won't be using mesa.
So any DRI stuff in glxinfo is bad, as it's means that you're using mesa, which is unable to run Eschalon correctly.

obiwan
Fellowcraft Apprentice
Posts: 52
Joined: October 31st, 2008, 10:59 am

Re: Painfully slow on recent computer

Post by obiwan » May 31st, 2010, 6:29 am

regnak90:

OpenGL renderer string: Mesa DRI R300
on my radeon card works fine thank you.

I wouldn't surprise me that even nouveau would more or less work on some nvidia cards. It is not 2006 anymore....

regnak90
Initiate
Posts: 5
Joined: May 29th, 2010, 2:25 pm

Re: Painfully slow on recent computer

Post by regnak90 » June 1st, 2010, 1:21 pm

So you're using Mesa.
We may not be in 2006, but Mesa is :)
You want to play Eschalon with decent frame rate ? Just use fglrx.
But it won't be that simple of course.
As you may already know, AMD dropped all cards under R600 with fglrx 9.4, so you will have to use an old kernel and xserver in order to use fglrx 9.3 (the last one that support your hardware).

And yeah, i do not doubt that your radeon card is working fine, but it is a fact that mesa is *not fast* with OpenGL. Yeah, some 3D games works fine, but Eschalon with his 2D Engine is slow.

EDIT: If you don't want to use an older distro, you can try using last mesa/libdrm/xf86-video-ati/kernel and try KMS + Gallium3D.
This is supposed to be faster than classic mesa, but it is still realy young and not realy optimized yet.

Tyranthraxus
Steward
Posts: 76
Joined: May 17th, 2009, 4:15 pm
Location: Valjevo Castle, Phlan

Re: Painfully slow on recent computer

Post by Tyranthraxus » June 8th, 2010, 5:57 pm

Well, after the LiveCD test, I finally decided to give Lucid Lynx a whirl on my laptop (dual core Toshiba Satellite Pro).
Everything seemed fine, until I tried to run Book II, the intro ran (with sound), seemed reasonable, although the `comet` seemed rather jerky and slow.
But once the menu came up, everything went as slow as the LiveCD with bugger-all memory on the slower desktop!
Couldn`t get into new game at all, and had a hard time exiting.

Anyway, after a lot of playing around, installing the latest proprietary Nvidia drivers seemed to do the trick, visual effects weren`t on anyway.

Too late to start a game now, need some food, and I`m not even going to try to find where ALSA has gone, but the free option seems to work, so I`ll leave that bit of fun for another time.

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Painfully slow on recent computer

Post by SpottedShroom » February 2nd, 2011, 4:01 pm

I recently installed Eschalon Book II on a new computer, this one with an ATI card instead of the Nvidia I've used in the past. Echoing people above, you must use the proprietary fglrx/Catalyst driver to get acceptable performance. Ubuntu maverick ships with the open source "radeon" driver, which is not up to the job. I even tracked down and installed the latest Gallium3D-based r600g DRI driver, but it wasn't much help.

The instructions here should help Ubuntu users set it up:

https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests