How to keep aspect ratio in full screen mode in ubuntu 10.04

Linux support forums for Eschalon: Book II
Post Reply
rocketsboy
Pledge
Posts: 2
Joined: June 10th, 2010, 10:49 pm

How to keep aspect ratio in full screen mode in ubuntu 10.04

Post by rocketsboy » June 10th, 2010, 11:24 pm

Hi all. I'm playing Eschalon: Book 2 on my laptop running ubuntu 10.04. My screen's native resolution is 1280 by 800. So I cannot see the whole game window in windowed mode as the system trays, title bar and window borders collectively occupy more than 32 pixels. And in the full screen mode the picture stretched in a way I really dislike. More specifically I hate the blurred characters which are harmful for eyes.

In this post (http://www.basiliskgames.com/forums/vie ... f=3&t=1508) the admin mentioned the effect of 'maintain aspect ratio' which is exactly what I want. I went through hundreds of forum posts, wiki entries and faqs but still cannot figure out how to do it on ubuntu 10.04 as xorg.conf is no longer preferred. Because the game is compiled on ubuntu 10.04 I think the developers may know how to keep the aspect ratio.

Can anyone tell me how to do it or suggest an alternative solution?

bitsweep
Initiate
Posts: 11
Joined: April 25th, 2009, 11:28 pm

Re: How to keep aspect ratio in full screen mode in ubuntu 1

Post by bitsweep » June 11th, 2010, 3:32 am

I am not using Ubuntu, so I can't vouch that this will work. But here is what I do on my Gentoo laptop w/ nVidia graphics:

There is a program called 'nvidia-settings' that is partnered with the proprietary Nvidia graphics drivers. (There is likely a similarly named packaged under the Ubuntu package manager.) Run this utility program and you get a 2-pane interface, with the left side showing a "tree" of various options:

Xserver info
Xscreen0 info
Cursor Shadow
OpenGL Settings
...etc...
GPU0
Thermal Settings
DFP0 - (Seiko)
...etc....

What you are interested in is the 'DFP0' (may be named differently if you have multiple displays plugged in) "digital flat panel" setting. Click on that, and the right-hand pane will display some options. On my box there is a checkbox titled, 'Force Full GPU Scaling'--click that ON. Next there is a set of radio-buttons underneath the previous checkbox--you want the one titled 'Aspect Ratio Scaled'.

NOTE: When you change the settings, the screen will blank for a second and return. When you have those selected, QUIT the utility. At this point try running Eschalon again and it should give you a non-stretched display.

Now if you are using ATI graphics, there is an equivalent doo-hickey utility--can't recall the name off the top of my head. If you have Intel GFX, I have no idea how to help, but there is probably a scaling adjust utility as well.

Again though, I haven't ever tried Ubuntu, so I don't know where these utilities might live on your system. You can try doing 'which nvidia-settings' in a terminal window command-line to see if the program is even installed under that name.

Hope this helps.

rocketsboy
Pledge
Posts: 2
Joined: June 10th, 2010, 10:49 pm

Re: How to keep aspect ratio in full screen mode in ubuntu 1

Post by rocketsboy » June 11th, 2010, 12:17 pm

Solved! Thanks a lot. I'm using intel graphics. You really give me a good hint. I manned the intel driver and at last solved the problem by

Code: Select all

xrandr --output LVDS1 --set "scaling mode" "Center"
. If you are running book 1 you may prefer replace 'Center' with 'Full aspect'. And you can put this line into the .xprofile file in your home folder to avoid the trouble of setting it for every session. And this only works for intel. I don't know about nvidia and ati but i think you can refer above. I love you guys, the game and ubuntu. I don't think I can do this under windows. Thanks a lot.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests