Will there be a build with lower glibc requirements ?

Linux support forums for Eschalon: Book II
Xilanaz
Pledge
Posts: 1
Joined: June 12th, 2010, 1:03 am

Will there be a build with lower glibc requirements ?

Post by Xilanaz » June 12th, 2010, 1:06 am

Just wondering if there will be a build of Book II with lower glibc requirements, I know I can go bleeding edge towards the factory repositories but to be honest I rather not go that route.

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Will there be a build with lower glibc requirements ?

Post by SpottedShroom » June 12th, 2010, 6:29 am

I believe BasiliskWrangler promised a build compiled against an earlier version of glibc in another thread. He's got a lot on his plate right now, though, so he didn't give a specific date it would be done by. Maybe this will be the case for the 1.04 build when it's ready?

I-hate-captchas
Initiate
Posts: 12
Joined: May 26th, 2010, 6:59 am

Re: Will there be a build with lower glibc requirements ?

Post by I-hate-captchas » June 12th, 2010, 12:28 pm

I think it would be a safer bet to upgrade the distro. Right now I can't play book II because I have too much stuff on my plate as well and just can't afford a borked laptop because of the upgrade.

Tyranthraxus
Steward
Posts: 76
Joined: May 17th, 2009, 4:15 pm
Location: Valjevo Castle, Phlan

Re: Will there be a build with lower glibc requirements ?

Post by Tyranthraxus » June 14th, 2010, 1:26 pm

I-hate-captchas wrote:I think it would be a safer bet to upgrade the distro. Right now I can't play book II because I have too much stuff on my plate as well and just can't afford a borked laptop because of the upgrade.
I sincerely hope that doesn't end up being the case.
I took the risk, and although installing Ubuntu didn't bork my laptop, the distro itself has some serious problems.
IMHO, if it ends up having to be an Ubuntu specific game, or take some serious system editing on others to get Book2 to work, I feel that this could damage the game's reputation somewhat.
Book 1 received a lot of praise for being so Linux friendly, if Book 2 ends up as Windoze/Mac/Ubuntu, instead of Windoze/Mac/Linux, it will surely affect take-up, or cause some indignant consumers who are unable to run it on fairly standard distros.

User avatar
CycyX
Fellowcraft Apprentice
Posts: 48
Joined: May 26th, 2010, 7:54 am
Location: France
Contact:

Re: Will there be a build with lower glibc requirements ?

Post by CycyX » June 14th, 2010, 4:07 pm

Does "fairly standard" means outdated?

Because I can run pretty much any game on my ArchLinux (rolling distro rules :wink:), and I'm pretty sure a Gentto would be able to do so.

So Book II is definitely not an "ubuntu" game, but it needs an up-to-date glibc.

I agree, a build with a previous version would be good for a larger audience, but I wonder if BW has the time to do this...

Tyranthraxus
Steward
Posts: 76
Joined: May 17th, 2009, 4:15 pm
Location: Valjevo Castle, Phlan

Re: Will there be a build with lower glibc requirements ?

Post by Tyranthraxus » June 15th, 2010, 2:00 pm

CycyX wrote:Does "fairly standard" means outdated?
No, it means "stable". If you look at distrowatch, most of the mainstream distros are still shipping much earlier glibc versions, and quite a few of them do not carry 2.11 on the mirrors, obtaining that can be quite beyond the inexperienced user, (and even bloody hard for the experienced in some cases!).
CycyX wrote: Because I can run pretty much any game on my ArchLinux (rolling distro rules :wink:), and I'm pretty sure a Gentto would be able to do so.
As it came 'out of the box', or did you have to work at it to get it running?
CycyX wrote: So Book II is definitely not an "ubuntu" game, but it needs an up-to-date glibc.
Unfortunately, BlitzMax has made several assumptions, that require dependencies that are pretty much specific to Ubuntu, and a lot of other perfectly good distros need some tinkering 'under the bonnet' to get those dependencies.
It may "NEED" an up to date glibc, but it doesn`t need 2.11. Personally, I feel 2.6 is quite sufficient, although I can understand why some have called for 2.4 as the 'baseline', as that comprises the current stable release of Debian and others.
Again, I ask the question, "What if the Windoze version had been compiled under the accursed Vi$ta, or Win7, and demanded DirectX 10 or 11?"
Doesn't mean it doesn't work under DX9 or even 7, it does, why exclude potential customers unnecessarily?

Besides, there is a lot wrong with Ubuntu, the KUbuntu version is completely borked, and even the 'standard' Gnome version has problems. As an example: out of the box, it does have ALSA installed, however, nothing seems to recognise this, and on Book 2, it is not an option. Now, I can get my hands dirty in the shell, and force it, but is this what you would expect of the casual user? More likely, they`ll give it up as a bad job, and maybe then post negative "this game doesn`t work" comments on this, or another forum.
Not the kind of publicity Basilisk need, even if it was ill-informed.

CycyX wrote: I agree, a build with a previous version would be good for a larger audience, but I wonder if BW has the time to do this...
I think he has to, Book 1 had some rave reviews, because it was so easy to install and run, on a wide range of systems.
I have it on a minimal Mandriva system Flash Disk, meaning that I can take it with me, and play anywhere I can scrounge some time on a computer.
If it starts being to fussy about what OS variants it can run on, especially when it is not due to an essential system requirement, it doesn't look good.

Don;t get me wrong, I love the game, and put in a lot of hours trying to get it to run on a system that should have handled it with ease, the question is, should I have had to do that?

User avatar
CycyX
Fellowcraft Apprentice
Posts: 48
Joined: May 26th, 2010, 7:54 am
Location: France
Contact:

Re: Will there be a build with lower glibc requirements ?

Post by CycyX » June 16th, 2010, 4:43 am

Tyranthraxus wrote:As it came 'out of the box', or did you have to work at it to get it running?
I just had to install required packages, using standard package manager.
Tyranthraxus wrote:Unfortunately, BlitzMax has made several assumptions, that require dependencies that are pretty much specific to Ubuntu, and a lot of other perfectly good distros need some tinkering 'under the bonnet' to get those dependencies.
I think basically BlitzMax just used whatever libs it finds on the compiling system as requirement, which may be really bad. But BW didn't thought about that.
And to be honest, if I used to have an Ubuntu distro as a workstation, I wouldn't have thought about installing a Debian "stable" in order to compile my project...
Tyranthraxus wrote:Don't get me wrong, I love the game, and put in a lot of hours trying to get it to run on a system that should have handled it with ease, the question is, should I have had to do that?
I agree, we shouldn't have to do that, but are we Linux users or not (meaning: are we looking for trouble? :wink: )

The Noid
Fellowcraft Apprentice
Posts: 53
Joined: September 11th, 2008, 6:54 am

Re: Will there be a build with lower glibc requirements ?

Post by The Noid » June 16th, 2010, 5:01 am

I suppose Debian Stable is a pretty good lowest common denominator. The current one, Lenny, uses 2.7 (http://packages.debian.org/stable/libc6)

The previous version of Ubuntu would probably also be a good system to compile on.

Tyranthraxus
Steward
Posts: 76
Joined: May 17th, 2009, 4:15 pm
Location: Valjevo Castle, Phlan

Re: Will there be a build with lower glibc requirements ?

Post by Tyranthraxus » June 16th, 2010, 1:02 pm

CycyX wrote: I just had to install required packages, using standard package manager.
Score brownie point for ArchLinux. If you try it with other distros, Mandriva, Slackware and Fedora come to mind, glibc 2.11 isn't carried in the standard repositories.

CycyX wrote: I think basically BlitzMax just used whatever libs it finds on the compiling system as requirement, which may be really bad. But BW didn't thought about that.
And to be honest, if I used to have an Ubuntu distro as a workstation, I wouldn't have thought about installing a Debian "stable" in order to compile my project...
It is bad, and it restricts a lot of potential users needlessly.
To be honest, I'm surprised anybody would have kept this version of Ubuntu on their computer long enough to compile at all. I've only installed it to get Book2 running, and as soon as I can get it running on something else, Ubuntu is coming off, I haven't seen a mess like that since Windoze95 1st Edition! (Although Millenium Dome edition and the accursed Vi$ta come close).
Clearly, this is a lesson for the future, now we know about BlitzMax's limitations, the baseline should be drawn where the majority of distros fall in the current distrowatch tables. Besides, Ubuntu's use of proprietary/non-free code should have rung alarm bells from the beginning, that's an accident waiting to happen for the majority of Linux users.

CycyX wrote: I agree, we shouldn't have to do that, but are we Linux users or not (meaning: are we looking for trouble? :wink: )
Sure, but I was putting myself in the place of the average/inexperienced user. Not everybody is going to go to the lengths that somebody like phaedrus did, I'd still be banging my head against the wall of that problem.
If we want a Book3, then Book2 has to do well, and that means being available to as many users as possible, not just Ubuntu 10 users, and BOFH's. :twisted:

Elwro
Senior Steward
Posts: 97
Joined: December 25th, 2007, 1:43 pm

Re: Will there be a build with lower glibc requirements ?

Post by Elwro » June 16th, 2010, 5:06 pm

Yeah, one reason I still have Karmic (and not Lucid) on my main computer is that---and I've been using Ubuntu for a few years---new versions of Ubuntu are not exactly improvements. They're changes. Some things which worked nicely stop working at all. Some new features are introduced, stuff gets rearranged for good or bad reasons. I have four versions on four PCs and so far the one which gave me least trouble is 9.04. The upgrade to 10.04 I did on one computer broke printing so effectively I can now only print PDFs, in Ubuntu (!), from KDE-based apps like Okular. I'm not making the version change just to play a single game.

Slammer64
Apprentice
Posts: 22
Joined: June 7th, 2010, 1:09 pm
Location: The Ozark Mountains of Missouri

Re: Will there be a build with lower glibc requirements ?

Post by Slammer64 » June 16th, 2010, 7:05 pm

Just an FYI Tyranthraxus, but ArchLinux is using glibc 2.12 in it's core repo.
Somewhere, just out of sight, the Penguins are gathering!

Tyranthraxus
Steward
Posts: 76
Joined: May 17th, 2009, 4:15 pm
Location: Valjevo Castle, Phlan

Re: Will there be a build with lower glibc requirements ?

Post by Tyranthraxus » June 17th, 2010, 2:54 pm

Slammer64 wrote:Just an FYI Tyranthraxus, but ArchLinux is using glibc 2.12 in it's core repo.
Just as well BW didn't compile on that then, or even Ubuntu users would be struggling. :!:

User avatar
sirdilznik
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 439
Joined: April 15th, 2010, 5:40 am

Re: Will there be a build with lower glibc requirements ?

Post by sirdilznik » June 17th, 2010, 4:12 pm

This is definitely not just an "Ubuntu game". Worked "out of the box" for me with Fedora 13.
Will Pay For Cloth Map

Slammer64
Apprentice
Posts: 22
Joined: June 7th, 2010, 1:09 pm
Location: The Ozark Mountains of Missouri

Re: Will there be a build with lower glibc requirements ?

Post by Slammer64 » June 17th, 2010, 6:13 pm

Agreed sirdilznik, worked out of the box on Arch too. Just had to download the requisite libraries for x64 and boom, I was off and playing.
Somewhere, just out of sight, the Penguins are gathering!

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Will there be a build with lower glibc requirements ?

Post by SpottedShroom » June 19th, 2010, 9:20 pm

We should chip in to buy BW a 486 running RedHat 5.2, and have him do all of his Linux builds on that :)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests