2 possible bugs in 1.04 final?

Linux support forums for Eschalon: Book II
Post Reply
The Muffinator
Pledge
Posts: 4
Joined: July 11th, 2010, 10:28 pm
Location: Houston, TX

2 possible bugs in 1.04 final?

Post by The Muffinator » July 11th, 2010, 11:02 pm

To Basilisk Wrangler (+ anyone else who can verify):

I think I've found two bugs, one of them pretty heinous. I just downloaded the 1.04 final version this afternoon and have been mucking about with it, using a rogue-ish character I had created under 1.03b or thereabouts.

Thus, I don't know if these bugs are:
(a) A linux-only issue.
(b) An interaction issue caused because the character was created in an earlier game version.
(c) possible on any platform, on any game version.

Bug #1 is shown in the attached screenshot. Basically, I was faffing about near Hammerlorne, and then used QuickTravel to pop to BrokenBlade. As you can see, both graphically and in the narrative text, I magically translocated an entire weather system with me--snow in Fellpine Forest!

Bug #2 is a bit nastier, and unfortunately I don't have a screenshot, but I'll do my best to describe it. The root problem (I think) is that one of the Goliath Boreheads walked "off the map".

I was very near the western edge of Eastern Fellpine map quad, with 2 beetles after me--I'd hit them both with 1 or 2 arrows. I holed up between a couple of trees so I wouldn't get gored when stunned, and was just plinking away with some arrows. One beetle kept looping in front of me, in that little brain-dead AI jitter they do. The second one hung about for a few rounds, then wandered off West along the little path. I killed the beetle in front of me, and then went chasing after the 2nd one. I walked clear to the western edge of the map--no beetle!?!?

Next I backtracked to the northern edge of the Eastern Fellpine, and as I approached the northern black border, it wasn't a black border. It was hundreds of overlapping sprites of the missing Goliath, just standing there!

I could get an aggressive target with my bow on any of them (showed the arrow icon + HP bar of the beetle), but I wasn't allowed to shoot.

The game also wouldn't allow me to walk northward off the map.

At this point I used QuickTravel to Port Kudaad, wondering if the game was going to crash. It didn't, and I just kept playing.

BUT (here we go)... Now I cannot finish the Goliath Beetle quest. Ol' druid whats-his-face keeps claiming that "an acolyte saw one just this past hour.."

To be clear here, I have combed all parts of the Fellpine map, Broken Blade, etc. repeatedly. There is no beetle.

Any suggestions?

To BW-- I don't know if this will help, but here's a suggestion as a programmer. While the AI may not walk off the map edges under their "normal" aimless wander because of bounds-checks, the missing beetle was definitely in "aggro" mode. (But not wounded enough to be in "oh crap! runaway!" mode.) Is there a loophole in that "aggro" pathing logic?

Thanks for another AMAZING game BTW!
Attachments
snowstorm.jpeg
snowstorm.jpeg (79.06 KiB) Viewed 3228 times
-The Muffinator
"Ain't never met a muffin that could get the best of me.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest