Can't run on Ubuntu Lucid 10.04 amd64

Linux support forums for Eschalon: Book II
Post Reply
shimi
Pledge
Posts: 2
Joined: July 16th, 2010, 3:12 pm

Can't run on Ubuntu Lucid 10.04 amd64

Post by shimi » July 16th, 2010, 3:15 pm

./eschalon_book_2: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3' not found (required by ./eschalon_book_2)
./eschalon_book_2: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4' not found (required by ./eschalon_book_2)
./eschalon_book_2: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3' not found (required by /usr/lib32/libGLU.so.1)
./eschalon_book_2: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4' not found (required by /usr/lib32/libGLU.so.1)

How can I run it?

User avatar
xolotl
Lieutenant
Lieutenant
Posts: 776
Joined: August 21st, 2008, 1:54 pm

Re: Can't run on Ubuntu Lucid 10.04 amd64

Post by xolotl » July 16th, 2010, 4:12 pm

I'm not personally familiar with Ubuntu packaging, but you probably need to install some kind of "gcc-compat" lib. Do a package search for "compat" and see what comes up; one of those should fix it for you. (Oh, and make sure that it's the 32-bit version that you're installing.)

shimi
Pledge
Posts: 2
Joined: July 16th, 2010, 3:12 pm

Re: Can't run on Ubuntu Lucid 10.04 amd64

Post by shimi » July 17th, 2010, 11:39 am

No package in the repos has the word "compact" in it's name..

User avatar
CrazyBernie
Captain Magnate
Captain Magnate
Posts: 1445
Joined: November 29th, 2007, 1:11 pm

Re: Can't run on Ubuntu Lucid 10.04 amd64

Post by CrazyBernie » July 17th, 2010, 12:02 pm

Check your spelling?? 0_o

User avatar
xolotl
Lieutenant
Lieutenant
Posts: 776
Joined: August 21st, 2008, 1:54 pm

Re: Can't run on Ubuntu Lucid 10.04 amd64

Post by xolotl » July 17th, 2010, 12:55 pm

shimi wrote:No package in the repos has the word "compact" in it's name..
Yeah, it'd be "compat" - you've got an extra c in there.

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Can't run on Ubuntu Lucid 10.04 amd64

Post by SpottedShroom » July 17th, 2010, 8:00 pm

Your libstdc++.so.6 is an old version. Since Ubuntu Lucid comes with the correct one (I know, since I'm running it myself) I wonder if something odd happened with your 32 bit libraries during an upgrade.

Try running:

apt-get install lib32stdc++6

That should update you to the latest version.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests