Not recognizing screen?

Linux support forums for Eschalon: Book II
Post Reply
Leviathan
Initiate
Posts: 9
Joined: June 3rd, 2012, 12:29 pm

Not recognizing screen?

Post by Leviathan » June 4th, 2012, 7:36 pm

Hi all, I'm a pretty inexperienced Linux user here, and I've ran across an error that I haven't been able to find anywhere using the search function. Attempting to run eschalon_book_2 using the Terminal resulted in the following error:

Code: Select all

X Error of failed request:   BadWindow (invalid Window parameter)
   Major opcode of failed request:     138  (NV-GLX)
   Minor opcode of failed request:     4  ()
   Resource id in failed request:       0x3a00002
   Serial number of failed request:    39
   Current serial number in output stream:     39
Some additional and potential relevant information is that I'm using release 10.10 Kernal Linux 2.6.35-24-generic with graphics card of NVIDIA 9800 GT
which apparently does not recognize my monitor and so I've had to mess around with some X display configuration files to even get my resolution to 1680x1050 (my monitor is an ACER AL2216W). Without the tinkering I've done, my monitor is set at 800x600 which is pretty bizarre.

Does anyone have an idea of what's going wrong here and what I can do to fix it? Thanks in advance.

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Not recognizing screen?

Post by SpottedShroom » June 5th, 2012, 6:55 am

The error's with NVidia GLX, so it sounds like your driver's not working correctly. What's the output of "glxinfo | head" ?

Leviathan
Initiate
Posts: 9
Joined: June 3rd, 2012, 12:29 pm

Re: Not recognizing screen?

Post by Leviathan » June 5th, 2012, 5:06 pm

Hi Mr.Shroom, thank you for the swift response! After installing mesa-utils and running glxinfo | head, here is the output:

Code: Select all


X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  138 (NV-GLX)
  Minor opcode of failed request:  4 ()
  Resource id in failed request:  0x3c00003
  Serial number of failed request:  30
  Current serial number in output stream:  30
name of display: :0.0

It seems that your suspicion was correct that this has something to do with NVidia's GLX (based on the similarities of the two reports)! Any recommendations on how to proceed from here?

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Not recognizing screen?

Post by SpottedShroom » June 6th, 2012, 9:55 am

I'd start by uninstalling and reinstalling the Nvidia binary drivers. You can find instructions here: https://help.ubuntu.com/community/Binar ... wto/Nvidia. Of course, that may reverse the changes you've made to xorg.conf to get your resolution working correctly, so make sure to keep a backup

If that doesn't work, could you post a copy of your xorg.conf and also your /var/log/Xorg.0.log?

Leviathan
Initiate
Posts: 9
Joined: June 3rd, 2012, 12:29 pm

Re: Not recognizing screen?

Post by Leviathan » June 6th, 2012, 9:40 pm

Ahh, thanks for the referral to that website; I was able to find relevant information about what my current problem is actually caused by (NVIDIA driver not being able to probe for supported resolutions, although the fact that it still doesn't recognize the existence of my monitor is disturbing >_>). Before I do anything rash, I'll post the log and configuration file here (this is under the kernal where I am able to use GUI; the other kernals where I didn't manually install the NVIDIA driver can only use command line)

configuration file

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 260.19.36  (buildmeister@swio-display-x86-rhel47-06.nvidia.com)  Tue Jan 18 17:31:39 PST 2011


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "ACER"
    ModelName      "ACER2216W"
    HorizSync      30-82
    VertRefresh    56-76
    Option         "DPMS"
    # 1680x1050 59.95 Hz (CVT 1.76MA) hsync: 65.29 kHz; pclk: 146.25 MHz
    Modeline "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
    # 1280x1024 74.90 Hz (CVT 1.31M4) hsync: 80.30 kHz; pclk: 138.75 MHz
    Modeline "1280x1024_75.00"  138.75  1280 1368 1504 1728  1024 1027 1034 1072 -hsync +vsync
    # 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
    Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option "UseEDID" "FALSE"
    Option "ExactModeTimingsDVI" "TRUE"
#    Option "UseEdidDpi" "FALSE"
#    Option "ModeDebug" "TRUE"
#    Option "ModeValidation" "NoWidthAlignmentCheck, NoDFPNativeResolutionCheck"
# Option "ModeValidation" "AllowInterlacecModes, NoTotalSizeCheck,AllowNon60HzDFPModes,NoEdidMaxPCl kCheck,NoVertRefreshCheck,NoHorizSyncCheck,NoDFPNa tiveResolutionCheck,NoVesaModes,NoEdidModes,NoXSer verModes,NoPredefinedModes,NoMaxSizeCheck,NoVirtua lSizeCheck,NoMaxPclkCheck,NoVertRefreshCheck"
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050_60.00" "1280x1024_75.00" "1280x1024_60.00" 
    EndSubSection
EndSection

log

Code: Select all

[  2232.567] 
X.Org X Server 1.9.0
Release Date: 2010-08-20
[  2232.568] X Protocol Version 11, Revision 0
[  2232.568] Build Operating System: Linux 2.6.24-29-server i686 Ubuntu
[  2232.568] Current Operating System: Linux JZ-Linux 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 01:41:57 UTC 2010 i686
[  2232.568] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-24-generic root=UUID=db87f00e-98fa-46d5-88ee-eb959da5fe3b ro quiet splash
[  2232.568] Build Date: 20 October 2011  03:03:54PM
[  2232.568] xorg-server 2:1.9.0-0ubuntu7.6 (For technical support please see http://www.ubuntu.com/support) 
[  2232.568] Current version of pixman: 0.18.4
[  2232.568] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  2232.568] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2232.568] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun  6 15:16:51 2012
[  2232.568] (==) Using config file: "/etc/X11/xorg.conf"
[  2232.568] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2232.569] (==) ServerLayout "Layout0"
[  2232.569] (**) |-->Screen "Screen0" (0)
[  2232.569] (**) |   |-->Monitor "Monitor0"
[  2232.569] (**) |   |-->Device "Device0"
[  2232.569] (**) |-->Input Device "Keyboard0"
[  2232.569] (**) |-->Input Device "Mouse0"
[  2232.569] (==) Automatically adding devices
[  2232.569] (==) Automatically enabling devices
[  2232.569] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  2232.569] 	Entry deleted from font path.
[  2232.569] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
	built-ins
[  2232.569] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[  2232.569] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  2232.569] (WW) Disabling Keyboard0
[  2232.569] (WW) Disabling Mouse0
[  2232.569] (II) Loader magic: 0x81f8e00
[  2232.569] (II) Module ABI versions:
[  2232.569] 	X.Org ANSI C Emulation: 0.4
[  2232.569] 	X.Org Video Driver: 8.0
[  2232.569] 	X.Org XInput driver : 11.0
[  2232.569] 	X.Org Server Extension : 4.0
[  2232.570] (--) PCI:*(0:1:0:0) 10de:0614:3842:c988 rev 162, Mem @ 0xfa000000/16777216, 0xe0000000/268435456, 0xf8000000/33554432, I/O @ 0x0000df00/128, BIOS @ 0x????????/131072
[  2232.570] (II) Open ACPI successful (/var/run/acpid.socket)
[  2232.571] (II) LoadModule: "extmod"
[  2232.571] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  2232.571] (II) Module extmod: vendor="X.Org Foundation"
[  2232.571] 	compiled for 1.9.0, module version = 1.0.0
[  2232.571] 	Module class: X.Org Server Extension
[  2232.571] 	ABI class: X.Org Server Extension, version 4.0
[  2232.571] (II) Loading extension MIT-SCREEN-SAVER
[  2232.571] (II) Loading extension XFree86-VidModeExtension
[  2232.571] (II) Loading extension XFree86-DGA
[  2232.571] (II) Loading extension DPMS
[  2232.571] (II) Loading extension XVideo
[  2232.571] (II) Loading extension XVideo-MotionCompensation
[  2232.571] (II) Loading extension X-Resource
[  2232.571] (II) LoadModule: "dbe"
[  2232.572] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  2232.572] (II) Module dbe: vendor="X.Org Foundation"
[  2232.572] 	compiled for 1.9.0, module version = 1.0.0
[  2232.572] 	Module class: X.Org Server Extension
[  2232.572] 	ABI class: X.Org Server Extension, version 4.0
[  2232.572] (II) Loading extension DOUBLE-BUFFER
[  2232.572] (II) LoadModule: "glx"
[  2232.572] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2232.572] (II) Module glx: vendor="X.Org Foundation"
[  2232.572] 	compiled for 1.9.0, module version = 1.0.0
[  2232.572] 	ABI class: X.Org Server Extension, version 4.0
[  2232.572] (==) AIGLX enabled
[  2232.572] (II) Loading extension GLX
[  2232.572] (II) LoadModule: "record"
[  2232.573] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  2232.573] (II) Module record: vendor="X.Org Foundation"
[  2232.573] 	compiled for 1.9.0, module version = 1.13.0
[  2232.573] 	Module class: X.Org Server Extension
[  2232.573] 	ABI class: X.Org Server Extension, version 4.0
[  2232.573] (II) Loading extension RECORD
[  2232.573] (II) LoadModule: "dri"
[  2232.573] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  2232.573] (II) Module dri: vendor="X.Org Foundation"
[  2232.573] 	compiled for 1.9.0, module version = 1.0.0
[  2232.573] 	ABI class: X.Org Server Extension, version 4.0
[  2232.573] (II) Loading extension XFree86-DRI
[  2232.573] (II) LoadModule: "dri2"
[  2232.573] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  2232.574] (II) Module dri2: vendor="X.Org Foundation"
[  2232.574] 	compiled for 1.9.0, module version = 1.2.0
[  2232.574] 	ABI class: X.Org Server Extension, version 4.0
[  2232.574] (II) Loading extension DRI2
[  2232.574] (II) LoadModule: "nvidia"
[  2232.574] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  2232.575] (II) Module nvidia: vendor="NVIDIA Corporation"
[  2232.575] 	compiled for 4.0.2, module version = 1.0.0
[  2232.575] 	Module class: X.Org Video Driver
[  2233.721] (II) NVIDIA dlloader X Driver  260.19.36  Tue Jan 18 17:12:14 PST 2011
[  2233.721] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  2233.721] (--) using VT number 7

[  2233.735] (II) Loading sub module "fb"
[  2233.735] (II) LoadModule: "fb"
[  2233.735] (II) Loading /usr/lib/xorg/modules/libfb.so
[  2233.736] (II) Module fb: vendor="X.Org Foundation"
[  2233.736] 	compiled for 1.9.0, module version = 1.0.0
[  2233.736] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  2233.736] (II) Loading sub module "wfb"
[  2233.736] (II) LoadModule: "wfb"
[  2233.736] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  2233.736] (II) Module wfb: vendor="X.Org Foundation"
[  2233.736] 	compiled for 1.9.0, module version = 1.0.0
[  2233.736] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  2233.736] (II) Loading sub module "ramdac"
[  2233.736] (II) LoadModule: "ramdac"
[  2233.736] (II) Module "ramdac" already built-in
[  2233.736] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[  2233.736] (==) NVIDIA(0): RGB weight 888
[  2233.736] (==) NVIDIA(0): Default visual is TrueColor
[  2233.737] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  2233.737] (**) NVIDIA(0): Option "UseEDID" "FALSE"
[  2233.737] (**) NVIDIA(0): Option "ExactModeTimingsDVI" "TRUE"
[  2233.737] (**) NVIDIA(0): Enabling RENDER acceleration
[  2233.737] (**) NVIDIA(0): Ignoring EDIDs
[  2233.737] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[  2233.737] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[  2233.737] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[  2233.737] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[  2233.737] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
[  2234.793] (II) NVIDIA(GPU-0): Not probing EDID on DFP-0.
[  2234.797] (II) NVIDIA(0): NVIDIA GPU GeForce 9800 GT (G92) at PCI:1:0:0 (GPU-0)
[  2234.797] (--) NVIDIA(0): Memory: 1048576 kBytes
[  2234.797] (--) NVIDIA(0): VideoBIOS: 62.92.89.00.84
[  2234.797] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  2234.797] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[  2234.797] (--) NVIDIA(0): Connected display device(s) on GeForce 9800 GT at PCI:1:0:0
[  2234.797] (--) NVIDIA(0):     DFP-0
[  2234.797] (--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
[  2234.797] (--) NVIDIA(0): DFP-0: Internal Dual Link TMDS
[  2234.863] (II) NVIDIA(0): Assigned Display Device: DFP-0
[  2234.863] (II) NVIDIA(0): Validated modes:
[  2234.863] (II) NVIDIA(0):     "1680x1050_60.00"
[  2234.863] (II) NVIDIA(0):     "1280x1024_75.00"
[  2234.863] (II) NVIDIA(0):     "1280x1024_60.00"
[  2234.863] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[  2234.903] (WW) NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI
[  2234.903] (WW) NVIDIA(0):     from DFP-0's EDID.
[  2234.903] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[  2234.903] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[  2234.903] (--) Depth 24 pixmap format is 32 bpp
[  2234.903] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[  2234.905] (II) NVIDIA(0): Initialized GPU GART.
[  2234.915] (II) NVIDIA(0): Setting mode "1680x1050_60.00"
[  2234.958] (II) Loading extension NV-GLX
[  2234.986] (II) NVIDIA(0): Initialized OpenGL Acceleration
[  2235.010] (==) NVIDIA(0): Disabling shared memory pixmaps
[  2235.010] (II) NVIDIA(0): Initialized X Rendering Acceleration
[  2235.010] (==) NVIDIA(0): Backing store disabled
[  2235.010] (==) NVIDIA(0): Silken mouse enabled
[  2235.017] (**) NVIDIA(0): DPMS enabled
[  2235.017] (II) Loading extension NV-CONTROL
[  2235.017] (II) Loading extension XINERAMA
[  2235.017] (II) Loading sub module "dri2"
[  2235.017] (II) LoadModule: "dri2"
[  2235.018] (II) Reloading /usr/lib/xorg/modules/extensions/libdri2.so
[  2235.018] (II) NVIDIA(0): [DRI2] Setup complete
[  2235.018] (==) RandR enabled
[  2235.018] (II) Initializing built-in extension Generic Event Extension
[  2235.018] (II) Initializing built-in extension SHAPE
[  2235.018] (II) Initializing built-in extension MIT-SHM
[  2235.018] (II) Initializing built-in extension XInputExtension
[  2235.018] (II) Initializing built-in extension XTEST
[  2235.018] (II) Initializing built-in extension BIG-REQUESTS
[  2235.018] (II) Initializing built-in extension SYNC
[  2235.018] (II) Initializing built-in extension XKEYBOARD
[  2235.018] (II) Initializing built-in extension XC-MISC
[  2235.018] (II) Initializing built-in extension SECURITY
[  2235.018] (II) Initializing built-in extension XINERAMA
[  2235.018] (II) Initializing built-in extension XFIXES
[  2235.018] (II) Initializing built-in extension RENDER
[  2235.018] (II) Initializing built-in extension RANDR
[  2235.018] (II) Initializing built-in extension COMPOSITE
[  2235.018] (II) Initializing built-in extension DAMAGE
[  2235.018] (II) Initializing built-in extension GESTURE
[  2235.033] (II) AIGLX: Screen 0 is not DRI2 capable
[  2235.033] (II) AIGLX: Screen 0 is not DRI capable
[  2235.035] (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
[  2235.036] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[  2235.059] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[  2235.070] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  2235.070] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2235.070] (II) LoadModule: "evdev"
[  2235.071] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  2235.071] (II) Module evdev: vendor="X.Org Foundation"
[  2235.071] 	compiled for 1.9.0, module version = 2.3.2
[  2235.071] 	Module class: X.Org XInput Driver
[  2235.071] 	ABI class: X.Org XInput driver, version 11.0
[  2235.071] (**) Power Button: always reports core events
[  2235.071] (**) Power Button: Device: "/dev/input/event1"
[  2235.084] (II) Power Button: Found keys
[  2235.084] (II) Power Button: Configuring as keyboard
[  2235.084] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[  2235.084] (**) Option "xkb_rules" "evdev"
[  2235.084] (**) Option "xkb_model" "pc105"
[  2235.084] (**) Option "xkb_layout" "ca"
[  2235.084] (**) Option "xkb_variant" "eng"
[  2235.087] (II) XKB: reuse xkmfile /var/lib/xkb/server-4BAE3EC55BAE54958C3D00FF1B2E21454ECF913F.xkm
[  2235.089] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  2235.089] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2235.089] (**) Power Button: always reports core events
[  2235.089] (**) Power Button: Device: "/dev/input/event0"
[  2235.104] (II) Power Button: Found keys
[  2235.104] (II) Power Button: Configuring as keyboard
[  2235.104] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[  2235.104] (**) Option "xkb_rules" "evdev"
[  2235.104] (**) Option "xkb_model" "pc105"
[  2235.104] (**) Option "xkb_layout" "ca"
[  2235.104] (**) Option "xkb_variant" "eng"
[  2235.106] (II) config/udev: Adding input device HID 0a5c:4502 (/dev/input/event4)
[  2235.106] (**) HID 0a5c:4502: Applying InputClass "evdev keyboard catchall"
[  2235.106] (**) HID 0a5c:4502: always reports core events
[  2235.106] (**) HID 0a5c:4502: Device: "/dev/input/event4"
[  2235.120] (II) HID 0a5c:4502: Found keys
[  2235.120] (II) HID 0a5c:4502: Configuring as keyboard
[  2235.120] (II) XINPUT: Adding extended input device "HID 0a5c:4502" (type: KEYBOARD)
[  2235.120] (**) Option "xkb_rules" "evdev"
[  2235.120] (**) Option "xkb_model" "pc105"
[  2235.120] (**) Option "xkb_layout" "ca"
[  2235.120] (**) Option "xkb_variant" "eng"
[  2235.121] (II) config/udev: Adding input device HID 0a5c:4503 (/dev/input/event5)
[  2235.121] (**) HID 0a5c:4503: Applying InputClass "evdev pointer catchall"
[  2235.121] (**) HID 0a5c:4503: always reports core events
[  2235.121] (**) HID 0a5c:4503: Device: "/dev/input/event5"
[  2235.140] (II) HID 0a5c:4503: Found 3 mouse buttons
[  2235.140] (II) HID 0a5c:4503: Found relative axes
[  2235.140] (II) HID 0a5c:4503: Found x and y relative axes
[  2235.140] (II) HID 0a5c:4503: Configuring as mouse
[  2235.140] (**) HID 0a5c:4503: YAxisMapping: buttons 4 and 5
[  2235.140] (**) HID 0a5c:4503: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  2235.140] (II) XINPUT: Adding extended input device "HID 0a5c:4503" (type: MOUSE)
[  2235.140] (II) HID 0a5c:4503: initialized for relative axes.
[  2235.140] (II) config/udev: Adding input device HID 0a5c:4503 (/dev/input/mouse1)
[  2235.140] (II) No input driver/identifier specified (ignoring)
[  2235.141] (II) config/udev: Adding input device USB Optical Mouse (/dev/input/event3)
[  2235.141] (**) USB Optical Mouse: Applying InputClass "evdev pointer catchall"
[  2235.141] (**) USB Optical Mouse: always reports core events
[  2235.141] (**) USB Optical Mouse: Device: "/dev/input/event3"
[  2235.156] (II) USB Optical Mouse: Found 3 mouse buttons
[  2235.156] (II) USB Optical Mouse: Found scroll wheel(s)
[  2235.156] (II) USB Optical Mouse: Found relative axes
[  2235.156] (II) USB Optical Mouse: Found x and y relative axes
[  2235.156] (II) USB Optical Mouse: Configuring as mouse
[  2235.156] (**) USB Optical Mouse: YAxisMapping: buttons 4 and 5
[  2235.156] (**) USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  2235.156] (II) XINPUT: Adding extended input device "USB Optical Mouse" (type: MOUSE)
[  2235.156] (II) USB Optical Mouse: initialized for relative axes.
[  2235.156] (II) config/udev: Adding input device USB Optical Mouse (/dev/input/mouse0)
[  2235.156] (II) No input driver/identifier specified (ignoring)
[  2235.157] (II) config/udev: Adding input device Sony PLAYSTATION(R)3 Controller (/dev/input/event6)
[  2235.157] (II) No input driver/identifier specified (ignoring)
[  2235.158] (II) config/udev: Adding input device Sony PLAYSTATION(R)3 Controller (/dev/input/js0)
[  2235.158] (II) No input driver/identifier specified (ignoring)
[  2235.164] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[  2235.164] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  2235.164] (**) AT Translated Set 2 keyboard: always reports core events
[  2235.164] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[  2235.176] (II) AT Translated Set 2 keyboard: Found keys
[  2235.176] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[  2235.176] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[  2235.176] (**) Option "xkb_rules" "evdev"
[  2235.176] (**) Option "xkb_model" "pc105"
[  2235.176] (**) Option "xkb_layout" "ca"
[  2235.176] (**) Option "xkb_variant" "eng"
By the way, is there any method of adding a scroll bar to a code section?

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Not recognizing screen?

Post by SpottedShroom » June 7th, 2012, 4:50 pm

Here's your problem:

Code: Select all

[  2232.572] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2232.572] (II) Module glx: vendor="X.Org Foundation"
...
[  2233.737] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[  2233.737] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[  2233.737] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[  2233.737] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[  2233.737] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
You should be loading the NVIDIA GLX module, not the X.Org one. By comparison, here's what mine looks like:

Code: Select all

[   103.913] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/libglx.so
[   103.942] (II) Module glx: vendor="NVIDIA Corporation"
Try adding this to the "Files" section of your xorg.conf:

Code: Select all

ModulePath      "/usr/lib/nvidia-current/xorg"

Leviathan
Initiate
Posts: 9
Joined: June 3rd, 2012, 12:29 pm

Re: Not recognizing screen?

Post by Leviathan » June 7th, 2012, 6:01 pm

Hmm... It appears that my "/usr/lib/nvidia-current/xorg" folder is empty. Perhaps this is an indication that my NVIDIA driver was not installed correctly? I feel that I am getting closer and closer to the root of all my problems.

After running xrandr -q, something that might be related happened:

Code: Select all


xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 175, current 1680 x 1050, maximum 1680 x 1050
default connected 1680x1050+0+0 0mm x 0mm
   1680x1050      50.0*    54.0     55.0     56.0     57.0  
   1280x1024      51.0     52.0     65.0     66.0     67.0  
   1024x768       53.0     77.0     78.0     79.0     80.0  
   1440x900       58.0  
   1400x1050      59.0     60.0     61.0     62.0  
   1360x768       63.0     64.0  
   1280x960       68.0     69.0  
   1152x864       70.0     71.0     72.0     73.0     74.0     75.0     76.0  
   960x600        81.0  
   960x540        82.0  
   840x525        83.0     84.0     85.0     86.0     87.0  
   832x624        88.0  
   800x600        89.0     90.0     91.0     92.0     93.0  
   720x450        94.0  
   720x400        95.0  
   700x525        96.0     97.0  
   680x384        98.0     99.0  
   640x480       100.0    101.0    102.0    103.0  
   640x400       104.0  
   640x350       105.0  
   512x384       106.0    107.0    108.0  
   400x300       109.0  
   320x240       110.0    111.0  
   320x175       112.0  
The line "default connected 1680x1050+0+0 0mm x 0mm" is particularly fishy, as looking at some other people's example lines, they have "VGA1", or "LVDS1" instead of "default".

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Not recognizing screen?

Post by SpottedShroom » June 7th, 2012, 8:48 pm

You're looking for libglx.so, which on my 12.04 system is in /usr/lib/nvidia-current/xorg and part of the nvidia-current package. You don't want the Xorg version, which on my system is in /usr/lib/xorg/modules/extensions. Do you have nvidia-current installed, and if so, what files does it contain? Run "dpkg -l nvidia-current".

Leviathan
Initiate
Posts: 9
Joined: June 3rd, 2012, 12:29 pm

Re: Not recognizing screen?

Post by Leviathan » June 8th, 2012, 7:18 pm

Thank you for the response. After running "dpkg -l nvidia-current" and checking out the /usr/lib/xorg/modules/extensions/ folder, it becomes very clear that the NVIDIA driver was not installed correctly. Here is the reading from the command:

Code: Select all

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  nvidia-current 260.19.06-0ubu NVIDIA binary Xorg driver, kernel module and
Edit/Update: After reinstalling the driver, the problem was fixed and here is the updated log after running "dpkg -l nvidia-current"

Code: Select all

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control, 
    GLX_EXT_swap_control, GLX_EXT_texture_from_pixmap, GLX_ARB_create_context, 
    GLX_ARB_create_context_profile, GLX_EXT_create_context_es2_profile,
Thank you Mr.Shroom for your help!

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Not recognizing screen?

Post by SpottedShroom » June 9th, 2012, 7:32 am

I'm glad we got that sorted for you. Enjoy Book II!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest