Exception_Access_Violation - On Starting Game

Windows support forum for Eschalon: Book III
User avatar
BasiliskWrangler
Site Admin
Posts: 3805
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Exception_Access_Violation - On Starting Game

Post by BasiliskWrangler » March 3rd, 2014, 1:44 pm

Here's the thing- it is extremely difficult to figure out why two or three people have a problem like this when a thousand other people don't.

A few other things to consider:

- OpenAL has been shown to crash the system upon start up. If you see OpenAL drivers listed in your Add/Remove Programs list, try taking them off.

- What happens if you delete the .cfg file completely? If the game starts after deleting the .cfg file, it is likely a setting you are choosing from the launcher that the game doesn't like after you exit and restart.

- Are you running Bit Locker or any other kind of drive compression or encryption? We don't use that on any of our test system- perhaps that is causing read/write failure of the saved game folders or .cfg file.

- Are you saving the game to a path with non-English letters? This shouldn't matter- it SHOULD work with a save path using any letters- but you might want to try a simplified save path with no non-English letters. How about saving to another drive altogether- the root of a flash drive, perhaps?

If we can find a fix that works, then we can identify the problem and work on a fix.
See my ramblings and keep up with the latest news on Twitter & Facebook.

ikbenrichard
Initiate
Posts: 12
Joined: February 19th, 2014, 12:52 pm

Re: Exception_Access_Violation - On Starting Game

Post by ikbenrichard » March 4th, 2014, 12:59 pm

Thank you for the answering.
Deleting the cfg file fix the problem. You do need to re enter the purchase code though.

I have filtered the problem. The sound option (any of the openAL options) is the problem.
audiodriver=DirectSound is working. Any other option is not.

Atleast i can play now.

Corlain
Apprentice
Posts: 26
Joined: June 21st, 2008, 8:44 pm

Re: Exception_Access_Violation - On Starting Game

Post by Corlain » March 6th, 2014, 10:20 am

This happens to me without OpenAL ever being installed, with OpenAL installed, and with OpenAL uninstalled.

No BitLocker or encryption of any kind.

Completely stock English install of Windows 8.1 Pro, no non-English letters in any path names anywhere.

Deleting the config file allows me to start the game, but as soon as I try to change it to something other than DirectSound or Null (because DirectSound might as well be Null for the sound it produces) it happens again. There is just no point in playing this game without music/sound as a good portion of my enjoyment of the game is the musical score.

I can change any other options besides sound, they stick just fine between sessions, and the game plays well. This is a sound option specific bug.

My sound chipset is RealTek hardware that is common to many Dell's. I tried it without updating my sound drivers and after updating my sound drivers, no difference. I have absolutely zero sound problems with literally everything else on my system, OS, programs, other games ranging in age from released this year to 10 years old.

Like I said before, the has something to do with whatever was changed with the sound system between the last revision of Book II and the first release of Book III. Book II, I can do whatever I want to the sound options and it works just fine, Book III, guaranteed crash.

If you have a debug version or something I can run to try and hammer this down, I'd be glad to do it to help. I want to play this damn game as much as you want it to work, that's why I'm so frustrated. I've been playing since Book I, I need to know how it all ends.

muze
Initiate
Posts: 10
Joined: November 20th, 2007, 12:57 pm

Re: Exception_Access_Violation - On Starting Game

Post by muze » March 24th, 2014, 1:00 am

This just started happening to me. I noticed there were sounds missing in the game - after many times playing the game, suddenly there was no ambient sound when I started playing tonight. I quit and switched the audio driver from DirectSound to OpenAL ASUS Xonar DX Audio Device - which is my sound card. Started the game, ambient sound was back, but other sounds missing or really really short, getting cutoff. I quit and now no matter what I select for audio driver I get the Exception_Access_Violation error message.

So I found the config file in C:\Users\xxxxxxxxx\AppData\Roaming\Basilisk Games\Book 3 Saved Games

Deleted it and that allows me to play.

When I set the sound to my sound card, the game will start once and then the error comes back.

Corlain
Apprentice
Posts: 26
Joined: June 21st, 2008, 8:44 pm

Re: Exception_Access_Violation - On Starting Game

Post by Corlain » March 24th, 2014, 8:05 am

So, that makes 3 people now.

User avatar
IJBall
Major
Major
Posts: 1684
Joined: August 31st, 2008, 11:07 am
Location: Southern California

Re: Exception_Access_Violation - On Starting Game

Post by IJBall » March 24th, 2014, 8:46 am

Prismatic Maelstrom wrote:Out of hundreds or thousands that haven't had a problem?
But it's repeatable. This is probably enough that it's worth looking in to.

This, combined with the problem some Linux people have been having with the sound system... potentially seems to point at the same set of issues.

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1371
Joined: June 4th, 2010, 6:18 pm

Re: Exception_Access_Violation - On Starting Game

Post by SpottedShroom » March 24th, 2014, 3:40 pm

IJBall wrote:
Prismatic Maelstrom wrote:Out of hundreds or thousands that haven't had a problem?
But it's repeatable. This is probably enough that it's worth looking in to.

This, combined with the problem some Linux people have been having with the sound system... potentially seems to point at the same set of issues.
The "getting cut off" thing is being seen more-or-less universally on Linux/OpenAL, so you may be right that they're connected. There is no OpenSound on Linux, though, so that facet is probably unrelated.

muze
Initiate
Posts: 10
Joined: November 20th, 2007, 12:57 pm

Re: Exception_Access_Violation - On Starting Game

Post by muze » March 26th, 2014, 2:15 am

The only reason I decided to change my sound driver was because of sounds missing, which led me to this error.

I'm back to using directsound, and sounds are still missing. Footsteps on areas besides grass, and doors opening for example. This started happening out of the blue. I had all the expected sounds for 17 hours of play. Pretty distracting to have these sounds missing now.

Corlain
Apprentice
Posts: 26
Joined: June 21st, 2008, 8:44 pm

Re: Exception_Access_Violation - On Starting Game

Post by Corlain » March 26th, 2014, 7:36 pm

I experience the same thing on the DirectSound option, which is why I initially tried changing the sound option.

jackgouber
Initiate
Posts: 11
Joined: October 15th, 2010, 9:26 pm

Re: Exception_Access_Violation - On Starting Game

Post by jackgouber » November 20th, 2014, 4:11 pm

Some of you people that post on here sound extremely arrogant. If one person has a problem with something and takes to time to post a thread on here for it, then he deserves the respect of everyone else regardless of how many people have the problem. I don't care if this is world of warcraft and 16 million users in it;s prime, if one person has a problem, it is worth consideration. I too am having this problem, I purchased the game from Steam along with civilatsation beyond earth and one other at the same time, installed back to back. I started the game after installing it, and for the last week, after I decided i actually wanted to pay, I get the window's message EXCEPTION_ACCESS_VIOLATION. I couldn't tell you if i changed anything in the sound part before running it at any time, probably not, the video setting i may have tried to change as I got a new monitor at the same time also. all around the first of this month. I tried the solution that said to go to c:\Users\*****\appdata, and it doesn't exist at least not there, he was probably refering to a version that is not from steam, but i looked through my steam apps folders too, and nothing like what he was saying in the eschalon 3 folder . I am going to try to get my money back from steam. But an interesting side note, you try to get support for this game on steam and they direct you to this forum, you try to get help on this forum, and steam gets blamed. Hah, Hah, basilisk games can kiss my ass. book 2 will be the only game i ever play from this lying ass single person company.

User avatar
BasiliskWrangler
Site Admin
Posts: 3805
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Exception_Access_Violation - On Starting Game

Post by BasiliskWrangler » November 21st, 2014, 7:28 am

jackgouber wrote:Hah, Hah, basilisk games can kiss my ass. book 2 will be the only game i ever play from this lying ass single person company.
Love you too.

Delete your entire saved games folder. That will fix your problem, which is caused by a bad configuration file or a malformed saved game folder.

Go to: C:\Users\usernasme\AppData\Roaming\Basilisk Games\

...and delete the Book 3 Saved Games folder completely. Restart the game (this rebuilds what you just deleted). If THAT doesn't fix your problem, then you have a hardware incompatibility, probably due to bad/outdated drivers.
See my ramblings and keep up with the latest news on Twitter & Facebook.

jackgouber
Initiate
Posts: 11
Joined: October 15th, 2010, 9:26 pm

Re: Exception_Access_Violation - On Starting Game

Post by jackgouber » November 25th, 2014, 4:18 pm

BasiliskWrangler wrote:
jackgouber wrote:Hah, Hah, basilisk games can kiss my ass. book 2 will be the only game i ever play from this lying ass single person company.
Love you too.

Delete your entire saved games folder. That will fix your problem, which is caused by a bad configuration file or a malformed saved game folder.

Go to: C:\Users\usernasme\AppData\Roaming\Basilisk Games\

...and delete the Book 3 Saved Games folder completely. Restart the game (this rebuilds what you just deleted). If THAT doesn't fix your problem, then you have a hardware incompatibility, probably due to bad/outdated drivers.

that was not a joke, I go to get support for this issue on steam and I got a link to this forum, then I come here and listen to your arrogant ass, and greedy IMHO, complain about having to address an issue that someone besides me had, and say things like, "how come only one person has this problem out of thousands???" does it really matter? Now there are two, and probably more>

Oh and in case your reading comprehension skills are a little sub-par, it should be obvious from my first post that the file path you have does not exist. If you can tell me where the saved games folder is in my steam version, then good, but the only thing in the steamapps/common/eschalonbook3 folder is data, start icon, and a couple of text files. so please stop repeating or copy and pasting what you already wrote on this thread and tell me something useful. Or are you evading the issue??? by whAT i'VE REAd on this forum about the patch for this game, which btw I had a big part of getting the steam version patched when there was a delay for book 2, I'll refer you to the only other thread I've posted on, and it was in 2010. So once again fuck you whatever your name is behind this handle.
Last edited by jackgouber on November 25th, 2014, 4:24 pm, edited 1 time in total.

jackgouber
Initiate
Posts: 11
Joined: October 15th, 2010, 9:26 pm

Re: Exception_Access_Violation - On Starting Game

Post by jackgouber » November 25th, 2014, 4:25 pm

Prismatic Maelstrom wrote:Did you try what was posted?
did you read what i posted?

I'll repeat what i said in retard language, that file doesn't exist on my computer, there is no appdata folder after users, on my computer, only folder and public.

User avatar
BasiliskWrangler
Site Admin
Posts: 3805
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Exception_Access_Violation - On Starting Game

Post by BasiliskWrangler » November 25th, 2014, 9:56 pm

jackgouber wrote:
Prismatic Maelstrom wrote:Did you try what was posted?
did you read what i posted?

I'll repeat what i said in retard language, that file doesn't exist on my computer, there is no appdata folder after users, on my computer, only folder and public.
Sorry, I should have mentioned: AppData is a hidden folder. You need to select "Show Hidden Files/Folders" for it to be visible.
See my ramblings and keep up with the latest news on Twitter & Facebook.

jackgouber
Initiate
Posts: 11
Joined: October 15th, 2010, 9:26 pm

Re: Exception_Access_Violation - On Starting Game

Post by jackgouber » November 26th, 2014, 2:13 pm

Prismatic Maelstrom wrote:
jackgouber wrote:did you read what i posted?
To be honest I only read the first couple of sentences because you came across as a bit of a dickhead.

And guess what? After reading your post just now, I wasn't wrong.
You are as condesending as they come and you call me a dick head, your damn right I am, to you.... I don't like snart ass punks like you.Who think they are smarter than everyone else, or think that if the problem doesn't affect them, then who cares???

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests