Default Keyboard Hot Keys Problem

Windows support forum for Eschalon: Book III
Post Reply
User avatar
tecknode
Initiate
Posts: 19
Joined: July 31st, 2012, 9:44 am
Contact:

Default Keyboard Hot Keys Problem

Post by tecknode » February 28th, 2014, 2:00 pm

When I use [F1] to see the Keyboard Hot Keys list, there's a problem.

The list has [Z] twice, it actually pulls up the Game Stats dialog.

There is no [S] listed which according to the general.cfg file is "charsheet=s" but using [S] does NOT work :(


ALSO: The ongoing problem (same with Book 1 & 2) with the game manual, the page "Quick Reference: Default Keyboard & Mouse Actions" is wrong. This page also states "altering the general.cfg" can change the keyboard hot keys, BUT since the file now says "charsheet=s" but [S] does NOT work.

Here is the full "general.cfg" file:

// Keyboard configuration
// NOTE: Tab, Esc, F1-F12, and Shift keys are reserved for the system and cannot be mapped.

inventory=i
charsheet=s
equip=e
spellbook=m
questjournal=q
torch=t
walklock=w
openall=x
screencap=p
walk_n=keypad8
walk_e=keypad6
walk_s=keypad2
walk_w=keypad4
walk_ne=keypad9
walk_se=keypad3
walk_sw=keypad1
walk_nw=keypad7
alchemy=a
combatmode=enter
camp=c
getall=g
passturn=space
selectlayout1=k
selectlayout2=l
gamestats=z



Need update for Eschalon Book II to make keyboard keys work properly.
Tecknomage
aka Master Blaster
Mage Pages

ikbenrichard
Initiate
Posts: 12
Joined: February 19th, 2014, 12:52 pm

Re: Default Keyboard Hot Keys Problem

Post by ikbenrichard » March 15th, 2014, 2:53 am

You can manually change the key settings. Just edit the general.cfg file.

User avatar
IJBall
Major
Major
Posts: 1684
Joined: August 31st, 2008, 11:07 am
Location: Southern California

Re: Default Keyboard Hot Keys Problem

Post by IJBall » March 15th, 2014, 1:14 pm

ikbenrichard wrote:You can manually change the key settings. Just edit the general.cfg file.
FTR, key "S" is naturally supposed to open the Player Stats window - it's been set for that since Book I.

So I'm not sure why your Book III app initially didn't have "S" set for that... Weird.

User avatar
xolotl
Lieutenant
Lieutenant
Posts: 776
Joined: August 21st, 2008, 1:54 pm

Re: Default Keyboard Hot Keys Problem

Post by xolotl » March 28th, 2014, 12:03 pm

Ah, I see there was a post about this after all. I always forget to check the actual support forums.

Anyway, a little more detail about this: The problem is actually that the engine takes whatever value is set for "gamestats" and applies it to "charsheet" as well. The value you set in general.cfg for "charsheet" never gets used at all. Change gamestats and BOTH keys get changed, as you can see in F1.

I've been just using "openall" (default of X), which works well enough for me, but it'd be nice to get it fixed, regardless.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests