Can't Launch Game

Windows support forum for Eschalon: Book I
Post Reply
Posts: 1
Joined: March 7th, 2017, 11:28 pm

Can't Launch Game

Post by Skeeter » March 7th, 2017, 11:46 pm

I had been playing Book 1 a while back and decided to return to it today. I have since upgraded my computer and this was the first time trying to play on my new machine. After clicking Play from Steam, the launch menu flashes for a second then disappears. The menu itself is just black, there are no controls visible. I could not find any forums posts with the same issue, so I'm guessing it has something to do with my PC. I downloaded the GoG version to try that, but get the same result.

My Steam version of Book 2 appears to work just fine; I see the launch menu and can get into the main game.

My video card is a GTX 1070, with the latest drivers as of today (378.66).

I've tried every setting in eschalon.cfg but it doesn't seem to make a difference.

Any ideas? Thanks!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest