Can't Launch Game

Windows support forum for Eschalon: Book I
Post Reply
Posts: 1
Joined: March 7th, 2017, 11:28 pm

Can't Launch Game

Post by Skeeter » March 7th, 2017, 11:46 pm

I had been playing Book 1 a while back and decided to return to it today. I have since upgraded my computer and this was the first time trying to play on my new machine. After clicking Play from Steam, the launch menu flashes for a second then disappears. The menu itself is just black, there are no controls visible. I could not find any forums posts with the same issue, so I'm guessing it has something to do with my PC. I downloaded the GoG version to try that, but get the same result.

My Steam version of Book 2 appears to work just fine; I see the launch menu and can get into the main game.

My video card is a GTX 1070, with the latest drivers as of today (378.66).

I've tried every setting in eschalon.cfg but it doesn't seem to make a difference.

Any ideas? Thanks!

Senior Council Member
Posts: 224
Joined: January 8th, 2012, 6:06 pm
Location: UK

Re: Can't Launch Game

Post by raverdave2k » June 30th, 2017, 7:40 am

Hey Skeeter,

I have also just sat down to start a new play through of the series and encountered the same problem, looks like you need to run as admin for it to work.

Navigate to your install directory (for Steam it's "<SteamLibraryPath>\steamapps\common\eschalon book i").
Right "eschalon_book_1.exe" and select properties.
Change to the "Compatibility" tab and tick "Run this program as an administrator" near the bottom of the page".

Ok out of all the dialogs and you can then click Play as normal.
My modifications for Eschalon Book I: RaverDave's Book I Mod
My modifications for Eschalon Book II: Port Kuudad Tower - Now Open, Treasure Of The Orakur

All previous versions avaliable here

Posts: 1
Joined: August 17th, 2017, 6:55 am

Re: Can't Launch Game

Post by crimsoncavalier » August 17th, 2017, 6:59 am


My issue is the same. I click on the launch game button, and the window flashes open for a split second, but then disappears. I've gone through and clicked the "run program as administrator" option, but that did not solve the issue.

This game runs fine on my Mac, but when I try to play it on my Windows computer, it simply does not work.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests