Crashes when I try to use opengl

Windows support forum for Eschalon: Book I
Post Reply
moneo
Initiate
Posts: 5
Joined: March 1st, 2008, 6:33 am

Crashes when I try to use opengl

Post by moneo » March 1st, 2008, 6:49 am

Hi,

Running windows vista,

when ever I try to load the game using opengl the introduction appears - but wrongly, just a white square moving where the orange glow should be, then it crashes.

the game works fine (but slowly) in direct x - I'd like to try using opengl.

what should I do?

User avatar
BasiliskWrangler
Site Admin
Posts: 3789
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Post by BasiliskWrangler » March 1st, 2008, 7:57 am

If under Vista, make sure you have the latest video drivers available and that Vista is patched completely.

moneo
Initiate
Posts: 5
Joined: March 1st, 2008, 6:33 am

Post by moneo » March 1st, 2008, 5:32 pm

Done & done, any more advice?

crimsonalucard
Pledge
Posts: 2
Joined: March 5th, 2008, 9:15 pm

Post by crimsonalucard » March 5th, 2008, 9:46 pm

I have the exact same problem.. Whats your video card?

huhlig
Initiate
Posts: 5
Joined: May 11th, 2008, 1:25 pm

Post by huhlig » May 11th, 2008, 2:06 pm

Same problem here. Rotating white square instead of the star

Vista SP1
2GB Ram
Intel GM965 Express Video Card
Inspiron 1525

huhlig
Initiate
Posts: 5
Joined: May 11th, 2008, 1:25 pm

Re: Crashes when I try to use opengl

Post by huhlig » August 14th, 2008, 2:34 pm

Was there ever an answer as to the rotating square and bad graphics in vista with opengl?

User avatar
BasiliskWrangler
Site Admin
Posts: 3789
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Crashes when I try to use opengl

Post by BasiliskWrangler » August 14th, 2008, 3:45 pm

I can almost guarantee this is a video driver problem with the Intel Express chipset. OpenGL is an API designed originally for CAD and design work, and many low-end chipsets (especially the Intel Express line) don't support OpenGL properly.

This isn't something we can fix. Try updating your drivers to the latest version, or run the game in DirectX mode. If DirectX is too slow, try changing to 16-bit color mode and/or changing the detail level to "low" in the options menu.
See my ramblings and keep up with the latest news on Twitter & Facebook.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests