Some issues

Windows support forum for Eschalon: Book I
Post Reply
Neueziel
Initiate
Posts: 13
Joined: July 24th, 2011, 1:05 pm

Some issues

Post by Neueziel » July 25th, 2011, 7:59 pm

Well so far from what i have read I have some doubts with some things:

1) It seems that when i run the game with Open Gl my character speed ups considerally but i have some graphical issues that I have read on other topics some White Tiles shows up...even on the rivers showed up full of white ´´tiles´´...now when i switch to Directx they disappear BUT my character walks slowly..If i reduce the graphics to low my char walks fast but i dont want to play the game with Low graphics...

2) In some screenshots that I have seen posted on the forums it seems the game is ´´bigger´´...I mean the character sprite seems Small when i play but when i see in the screenshots the game and the scenery seems bigger....

I posted on another topic my specs...128MB videocard, 4GB Ram and Intel core 2 Duo(laptop)...so i think that is strange the game runs with the ´´walk speed´´issue when some older 3D games like gothic or call of cthulhu never had slowdown problems....

Neueziel
Initiate
Posts: 13
Joined: July 24th, 2011, 1:05 pm

Re: Some issues

Post by Neueziel » July 25th, 2011, 8:04 pm

And I have the 1.06 version by the way...bought the game from the link on the main site....

User avatar
BasiliskWrangler
Site Admin
Posts: 3789
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Some issues

Post by BasiliskWrangler » July 25th, 2011, 8:30 pm

For starters, please make sure your video drivers are up-to-date.

Have you tried also switching between full screen and windowed mode?
See my ramblings and keep up with the latest news on Twitter & Facebook.

Neueziel
Initiate
Posts: 13
Joined: July 24th, 2011, 1:05 pm

Re: Some issues

Post by Neueziel » July 25th, 2011, 9:59 pm

My video drivers are updated and still the same white title problem on Open GL occurs...the rivers are full of those white tiles.....onlu switching to directx the white tile issue is gone...i tried to restart my pc and going into the game but the white tile problem on Open GL still remains...

And playing in windowed mode still doesnt affect my walking speed when using the directx configuration...

It would help to find a fix so I can play in Open GL without those white tiles issues since in Open GL my walking speed is kinda fast.....

Neueziel
Initiate
Posts: 13
Joined: July 24th, 2011, 1:05 pm

Re: Some issues

Post by Neueziel » July 26th, 2011, 2:42 pm

Its seems my problem is with OpenGL...everytime i switch to directX the white tiles vanish......but my performance rating in towns is like 31...even with 16-bit color activated....

This game is kinda of a ´´trap´´ since the graphics can lure you into thinking you dont need a stronger video card...I have an 128MB video card and apparently is not enough and it makes my core temp really go up...and walking into towns in ´´slow motion´´is really bothersome....i hope that into dungeons the performance rating dont shoot up like in towns....

User avatar
CrazyBernie
Captain Magnate
Captain Magnate
Posts: 1442
Joined: November 29th, 2007, 1:11 pm

Re: Some issues

Post by CrazyBernie » July 27th, 2011, 3:48 pm

It's not the graphics memory that's the culprit... it's the graphics chip itself. I did a test awhile back and was able to run the game on an older (another Compaq, this one from 2001) P4 laptop that only had a 32MB video card and it was pretty smooth - the memory was dedicated specifically to the video card, and it was an ATI-made chip (a Mobile radeon 7500, to be exact). Intel has always made a poor integrated graphics solution with the most barebones of capability... and they still advertised it as "great for gaming." Only with their newest chip (Sandy Bridge) have they got anything that remotely competes with the discrete solutions (AMD, NVIDIA).

I've got a couple of theories why the game does so poorly on the intel chips. One is that the chip might acually be able to process the relatively simple graphics of the game faster, but it requires some programming techniques/optimizations that BW is not aware of, since the cheaply designed card might use some non-standard functions to get the job done. Another is that it is a limitation of the BlitzMax engine that BW is using to create the game. Resolving either one would require time and resources that are likely not available to BW as an indie developer.

I will say that your dungeon performance should fare better... there's a lot less to be drawn on the screen, which always means a performance boost.

Neueziel
Initiate
Posts: 13
Joined: July 24th, 2011, 1:05 pm

Re: Some issues

Post by Neueziel » July 31st, 2011, 10:26 am

Hmm I see...yeah you may be right Bernie...the fault may be on the intel chipset itself...I mean i was suspicious since on my crazy days I finished Left 4 dead 1 and Borderlands on THIS laptop...even with somewhat poor FPS those games wouldnt crash down or anything....so yeah I stopped trying running those´´behemots´´on my laptop....

Well I am kind busy right now so someday I will get back to this game...cant resist medieval old school....and dont regret purchasing it anyway...

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests