Screen too dark for me

Windows support forum for Eschalon: Book I
Post Reply
User avatar
KillingMoon
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 460
Joined: December 10th, 2009, 6:34 pm
Location: NW Europe

Screen too dark for me

Post by KillingMoon » March 13th, 2012, 1:45 pm

I'm a long time owner of Book I, but have until now found it too problematic to play the game, as I hardly see anything on my screen when it's night in the game.
Book II was fine for me, with its brightness booster.

When I try playing Book I, I of course have my monitor on full brightness, but it doesn't help enough. Does anybody perhaps know of some trick or tool that could help me see what's happening on the screen?

User avatar
Kreador Freeaxe
Major General
Major General
Posts: 2365
Joined: April 26th, 2008, 3:44 pm

Re: Screen too dark for me

Post by Kreador Freeaxe » March 13th, 2012, 2:06 pm

Sit in a very dark room yourself. ;-)

In game, you can use Cat's Eyes and another light source (torch, lantern, Gravedigger's Flame) to give you the equivalent visibility of daylight.
---

Kill 'em all, let the sysadmin sort 'em out.

User avatar
SpottedShroom
Captain Magnate
Captain Magnate
Posts: 1368
Joined: June 4th, 2010, 6:18 pm

Re: Screen too dark for me

Post by SpottedShroom » March 13th, 2012, 2:13 pm

Depending on your video card and the driver you're using, you may be able to increase brightness or change gamma correction. Look under Display settings and Advanced, or run your video card configuration utility directly.

User avatar
KillingMoon
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 460
Joined: December 10th, 2009, 6:34 pm
Location: NW Europe

Re: Screen too dark for me

Post by KillingMoon » March 26th, 2012, 8:27 am

I'm biting the bullet and trying to play this game now regardless. I did find a setting for my video card that should have increased the brightness, but I didn't see any result.
I've set my default screen resolution to 600 x 800, to get the game to start in full screen mode, that at least worked, but the darkness and graphical glitches are difficult to get rid off.

For fun I'll show some screens of my game, to show how it looks for me, to begin with the launch menu, as that now tries to annoy me as well:

Image

At least that's not what I'm watching for a long time if I'm playing the game, I'm happy to assure you, but what I am looking at a lot is things like this:

Image

Some stretches of maps can be okay, but others can also be worse than this. This doesn't have a lot to day with my initial complaint of too much darkness in this game, I concede, but you get an idea of why I'm not really happy about how this game is displaying for me.

User avatar
Kreador Freeaxe
Major General
Major General
Posts: 2365
Joined: April 26th, 2008, 3:44 pm

Re: Screen too dark for me

Post by Kreador Freeaxe » March 26th, 2012, 9:18 am

You're getting that on Windows? That looks like the video bug that cropped up in the Mac versions with newer updates to OS X.

In Book I, darkness is really, really dark, yes. (It can even get that way in Book II, if you're wandering around on a stormy night, even with the brightness boosted to max.) You need to use some alternate visual source or light source most of the time when you're in a dungeon or cave or wandering at night.
---

Kill 'em all, let the sysadmin sort 'em out.

User avatar
KillingMoon
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 460
Joined: December 10th, 2009, 6:34 pm
Location: NW Europe

Re: Screen too dark for me

Post by KillingMoon » March 26th, 2012, 4:09 pm

Kreador Freeaxe wrote:You're getting that on Windows? That looks like the video bug that cropped up in the Mac versions with newer updates to OS X.
I found this thread: viewtopic.php?f=10&t=3998, yes, I'm getting that as well, so that's not Mac or Steam related. Although this usually disappears if I switch from Direct X to Open GL or the other way around. It happens in both settings, but just switching helps.

But I just lost a few hours of gameplay due to the autosave diappearing. I checked the slot and it's simply empty. It happened after a couple of 'access violation' messages, they are popping up again as well.

My computer simply does not like the Eschalon series. It is not one issue, it is one issue after the other, it's almost unbelievable.

User avatar
Kreador Freeaxe
Major General
Major General
Posts: 2365
Joined: April 26th, 2008, 3:44 pm

Re: Screen too dark for me

Post by Kreador Freeaxe » March 26th, 2012, 4:38 pm

Strange. I recommend sending details about your particular setup to BW, as that would help him in tracking down what could be causing the problems.
---

Kill 'em all, let the sysadmin sort 'em out.

User avatar
KillingMoon
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 460
Joined: December 10th, 2009, 6:34 pm
Location: NW Europe

Re: Screen too dark for me

Post by KillingMoon » March 27th, 2012, 9:22 am

What BasiliskWrangler is aware of is that some people had to download additional software - I think it was called Open AL - and disable their firewall and make sure no other program was running before Book II was even able to start.
I had to do all this as well, while with no other game I ever needed to.

Compatibility of the Eschalon series is somehow not great, and I would certainly recommend BasiliskWrangler to look into this for Book III.
But let him just get on with this Book III, I rather see him do that than doing anything else.

I'm just blowing off some steam here. The technical problems are sometimes ridiculous, but it just so happens that the last couple of game hours I spent with Book I have been extremely smooth and without a single glitch. I'm making sure I save more often now, incase of trouble popping up again.

User avatar
BasiliskWrangler
Site Admin
Posts: 3794
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Screen too dark for me

Post by BasiliskWrangler » March 28th, 2012, 1:34 pm

KillingMoon wrote:Compatibility of the Eschalon series is somehow not great,
The thing is, Book 1 for Windows has not been recompiled for a looong time. It's not that the game somehow broke itself, but rather operating systems evolve and become incompatible with older software.

In some cases, it is that players need to update their drivers, which will correct some of these anomalies caused when OSs and APIs are updated.

I certainly do not want anyone to have to play the game with glitchy graphics, and we can pull out the Book I code and recompile it if needed. Is any other windows user seeing this glitch?
See my ramblings and keep up with the latest news on Twitter & Facebook.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests