Eschalon Book 1 on Surface Pro in Fullscreen

Windows support forum for Eschalon: Book I
Post Reply
Chod
Initiate
Posts: 10
Joined: July 29th, 2011, 12:48 am

Eschalon Book 1 on Surface Pro in Fullscreen

Post by Chod » July 4th, 2013, 6:48 pm

Hi Guys,

I thought i would go back and play through Book 1 on my Surface Pro. I managed to get everything running, however, when the game runs in fullscreen it is terribly slow. Each movement takes 2 seconds. Yet when in windowed mode it plays fine.

Eschalon book 2 plays fine in windowed and fullscreen.

Are there any optimizations that someone could recommend to get it running more smoothly in fullscreen?

I have updated the drivers to the latest intel 4000 drivers.

At worst, i can always play this in windowed mode. Would prefer the immersion of fullscreen though.

Also if anyone has problems with the scaling of the UI... the surface pro has dpi scaling on by default. You need to disable it using compatibility mode. If you right click on the eschalon exe (or any exe for that matter) you can go to properties and compatibility to disable the DPI scaling. This should fix any issues to do with that.

Cheers,

Chod.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests