unplayably slow on Hardy w/ Radeon 9000

Linux support forum for Eschalon: Book I
Post Reply
Posts: 1
Joined: March 9th, 2009, 11:44 pm

unplayably slow on Hardy w/ Radeon 9000

Post by jjf »

First of all, I've played the Eschalon demo on my Vista PC. It looks great! I love old school RPGs, so I really hope I can get this working on my Linux laptop.

I have a Thinkpad T40 running Ubuntu Hardy with a Radeon 9000 graphics card. When I launch Eschalon, the game runs so slowly that it's unplayable. For example, on the main menu the mouse lags badly. I click "Start New Adventure" and have to wait 30 seconds while the menu selection glows brighter yellow, the screen fades, the Create New Character screen comes up. In the character creation screen, the mouse continues to lag, sometimes I have to click something two or three times for it to register, the graphical flourishes (like the starburst when you select a region, axiom, class) are painfully slow, etc.

Just to be very clear, this isn't just a performance issue (i.e., "the game isn't as fast as I want"). It really is unplayable this way. I've tried Windowed and Full-Screen, 16-bit and 32-bit. Nothing works.

I know my graphics card has the chops to run this game because (1) in WinXP (I dual-boot), I'm able to run Neverwinter Nights, which is more graphically demanding; and (2) someone on the Ubuntu forums mentioned he could play it with his Radeon 7500 (and mine's a 9000).

So I'm pretty sure it's a graphics driver issue.

I'm using the open-source radeon driver. The Ubuntu Wiki says my card is too old to run the proprietary frglx (or whatever it's called) driver from ATI.

Any help would be appreciated. Thanks!
Posts: 3
Joined: January 27th, 2009, 7:41 pm

Re: unplayably slow on Hardy w/ Radeon 9000

Post by dfa_geko »

Have you tried to disable compiz before playing?
Post Reply