Equipping trousers leads to segfault

Linux support forums for Eschalon: Book II
Post Reply
Wolverine
Initiate
Posts: 13
Joined: May 26th, 2010, 4:50 pm
Location: Bavaria

Equipping trousers leads to segfault

Post by Wolverine »

Hi

When I try to equip my new trousers (Iron chain leggings) the game crashes. Other trousers are working without problems.
I'm using a 64bit gentoo.
Attachments
eb2_screen0.jpg
eb2_screen0.jpg (149.54 KiB) Viewed 7226 times
User avatar
BasiliskWrangler
Site Admin
Posts: 3810
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Equipping trousers leads to segfault

Post by BasiliskWrangler »

Could you post a saved-game with this?
See my ramblings and keep up with the latest news on Twitter & Facebook.
Wolverine
Initiate
Posts: 13
Joined: May 26th, 2010, 4:50 pm
Location: Bavaria

Re: Equipping trousers leads to segfault

Post by Wolverine »

for sure... I assume just taring the complete directory does the trick?
Attachments
savegame.tar.gz
(70.15 KiB) Downloaded 294 times
User avatar
BasiliskWrangler
Site Admin
Posts: 3810
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Equipping trousers leads to segfault

Post by BasiliskWrangler »

Hmmm. Doesn't crash for me.

When you equip the chain leggings, it plays a sound and updates the in-game sprite of the character. For you, the game must be crashing when it tries to access one of these resources.

Is there any way to get more info from your system about this crash?
See my ramblings and keep up with the latest news on Twitter & Facebook.
User avatar
sirdilznik
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 439
Joined: April 15th, 2010, 5:40 am

Re: Equipping trousers leads to segfault

Post by sirdilznik »

If you run 'eschalon_book_2' from the command prompt does it spit out anything after the crash in the terminal window?
Will Pay For Cloth Map
Wolverine
Initiate
Posts: 13
Joined: May 26th, 2010, 4:50 pm
Location: Bavaria

Re: Equipping trousers leads to segfault

Post by Wolverine »

sirdilznik wrote:If you run 'eschalon_book_2' from the command prompt does it spit out anything after the crash in the terminal window?
Just "segmentation fault".

The informations I get are very poor.
Starting eschalon with gdb just leads to the following:

0x0815fd1c in ?? ()
(gdb) bt
#0 0x0815fd1c in ?? ()
#1 0x0811371c in ?? ()
#2 0x0810362d in ?? ()
#3 0x080d289d in ?? ()
#4 0x080ce2e5 in ?? ()
#5 0x0804d0c4 in ?? ()
#6 0xf7a5fbb6 in __libc_start_main () from /lib32/libc.so.6
#7 0x0804cfe1 in ?? ()


Dmesg states:
eschalon_book_2[3528]: segfault at 34 ip 000000000815fd1c sp 00000000ff9cc4d8 error 4 in eschalon_book_2[8048000+131000]

Perhaps recompiling my system with -ggdb as an additional CFLAG could help getting more detailed information. But this would take some time...
If anyone here has some ideas how to get more informations about the crashing process - just tell me ;)
obiwan
Fellowcraft Apprentice
Posts: 52
Joined: October 31st, 2008, 10:59 am

Re: Equipping trousers leads to segfault

Post by obiwan »

I got the same problem with these trousers.
obiwan
Fellowcraft Apprentice
Posts: 52
Joined: October 31st, 2008, 10:59 am

Re: Equipping trousers leads to segfault

Post by obiwan »

Actually, my trousers are bronze. And I think I can still hear the heavy armor sound playing before it segfaults.

without a non-stripped binary eschalon it is difficult to debug further:(

It could be interaction with the opengl driver. I am on the OS ati driver. Wolverine?
User avatar
sirdilznik
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 439
Joined: April 15th, 2010, 5:40 am

Re: Equipping trousers leads to segfault

Post by sirdilznik »

I had the same thing happen to me trying to put on trousers. I also couldn't get more of an error message than 'segmentation fault (core dumped)'. At first I figured it might be the sound, knowing the unfortunately jumbled mess that is audio in Linux, but changing between FreeAudio, OpenAL, and even null made no difference. Changing from full screen to windowed made no difference either.

This is on Fedora 13 x86_64
nVidia GTX260
nvidia driver 195.36.24

I guess I'll just have to go commando-style for now :wink: :lol:
Will Pay For Cloth Map
Wolverine
Initiate
Posts: 13
Joined: May 26th, 2010, 4:50 pm
Location: Bavaria

Re: Equipping trousers leads to segfault

Post by Wolverine »

obiwan wrote:It could be interaction with the opengl driver. I am on the OS ati driver. Wolverine?
Maybe...some of my system details:
xorg-server 1.8.1-r1
nvidia-drivers 195.36.24
glibc 2.11.1
Linux 2.6.32-gentoo-r5.wolvnet
User avatar
BasiliskWrangler
Site Admin
Posts: 3810
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Equipping trousers leads to segfault

Post by BasiliskWrangler »

Ah! I found the problem.

No worries on your end, it's not a driver issue. I'll fix it up.
See my ramblings and keep up with the latest news on Twitter & Facebook.
User avatar
BasiliskWrangler
Site Admin
Posts: 3810
Joined: July 6th, 2006, 10:31 am
Location: The Grid
Contact:

Re: Equipping trousers leads to segfault

Post by BasiliskWrangler »

See my ramblings and keep up with the latest news on Twitter & Facebook.
Wolverine
Initiate
Posts: 13
Joined: May 26th, 2010, 4:50 pm
Location: Bavaria

Re: Equipping trousers leads to segfault

Post by Wolverine »

Another problem solved. Thanks ;)
User avatar
sirdilznik
Officer [Gold Rank]
Officer [Gold Rank]
Posts: 439
Joined: April 15th, 2010, 5:40 am

Re: Equipping trousers leads to segfault

Post by sirdilznik »

Awesome job fixing the issue so quickly BW! Much appreciated.

Edit: Now I don't have to run around Mistfell bare ass nekkid no more:

Image

:lol:
Will Pay For Cloth Map
Post Reply